Jeep Dodge Nitro Dodge Challenger Dodge Charger Chrysler 300 Dodge Caliber Dodge Avenger
Jeep Forum Dodge Nitro Forum Dodge Challenger Forum
Dodge Charger Forum Chrysler 300 Forum Dodge Caliber Forum Dodge Avenger Forum


DODGE RAM FORUM
DODGE RAM PICTURES

View Full Version : Sat Radio Reception


bobohio
07-06-2013, 11:12 PM
Is anyone else having reception issues with the Sat radio? I had Sat radio in my old Jeep Commander and it was an aftermarket one at that and I rarely lost signal. I travel the same roads with my new Ram and have a lot of lost signal issues, seems to be the tree cover, but it's not any different than when I had my jeep. I have asked other people who drive the same road as I do and they also don't have any issues. Have taken to the dealer on 3 different occasions and they found nothing wrong. I had Sirius do a refresh and still not any better. Anyone have any ideas?

nikeman
07-06-2013, 11:18 PM
It's pretty common in our trucks. I just noticed how bad mine was today driving under a lot of trees. It seems that if the trees stay overhead for 3 seconds or more the signal is lost. It went out for a while during one of my daughters favorite songs today and she was mad. Lol. Signal came back right at the end of the song too.

GTyankee
07-07-2013, 12:23 AM
You Jeep may have had the actual Sirius
the 2013 Ram has what they are calling Sirius XM
although they merged a while back
I THINK
XM only uses GEO Stationary Satellites & i believe that there are Only 2 of them, they depend on Repeaters that are on the Earth, usually on a high point & far from adequate

A geosynchronous satellite is a satellite whose orbital track on the Earth repeats regularly over points on the Earth over time. If such a satellite's orbit lies over the equator, it is called a geostationary satellite. The orbits of the satellites are known as the geosynchronous orbit and geostationary orbit.

bstunder
07-07-2013, 03:50 AM
Upgrading the software for the radio/controls helped on mine. Still not the reception of my 2008 F-150 with Sirius or my wife's car. It did improve it from totally pathetic to pathetic.

arietem
07-07-2013, 06:15 PM
So far so good, in the city .. out of the city .. working very well .. even with cloud cover..

Eurotrash
07-07-2013, 08:17 PM
Exact same issues as everyone. My 2011 was perfect with zero lost signals unless underground parking.
This new truck sux for sat reception and Bluetooth clarity.
Not sure if it is related to the Sirius vs Sirius xm change.

macabra11
07-15-2013, 12:22 PM
I just picked up my new 2013 Ram on Saturday and noticed something strange. Some of the stations are perfectly clear while others are crackly and sound a little "tinny". I haven't listened through every channel, but my observation is that the music channels are great (Outlaw country, Lithium, etc), but when I tune to MLB Network Radio or a MLB Play by Play game, it is like you're listening to an FM station that is out of range.

Why would some stations be clear and others not? Anyone else experience this, or can someone test this?

Thunderhorse
07-15-2013, 01:47 PM
Even on FM most talk radio stations have always seemed less clear, they may not care to preserve the quality as much since its talk and not music but idk.

macabra11
07-15-2013, 01:54 PM
Even on FM most talk radio stations have always seemed less clear, they may not care to preserve the quality as much since its talk and not music but idk.

I would tend to agree, but I had an XM radio (aftermarket) on the truck that I traded in and the reception/clarity of the MLB channel was outstanding so I know it isn't that channel.

I am wondering if it has to do with the new 8.4n radios being both Sirius AND XM compliant. I'm not positive how this all works, but I am assuming it is getting signal from both Sirius AND XM satellites. Maybe the receiver/antennae is geared more towards the Sirius satellite? :4-dontknow: I'm just not sure who I should try first for fixing - siriusxm or dealer?

snrusnak
07-15-2013, 04:58 PM
Only time I lose reception is when signal path is lost like sitting under a concrete bridge.

Oldfatman
07-15-2013, 08:59 PM
Same issue with my '13 Big Horn W?8.4A radio. The attempted a "flash download" from Sirrius, but no improvement. They tried to tell me TI (Terrestrial Interference) trees etc, but I advised them that my wife's '12 T&C has NO issues with reception, even when traveling the same roads. In addition, I noticed that reception was excellent when traveling on the interstate, but breaks up or goes to "Acquiring Signal" when on the back roads with a few bumps here and there. My dealer's technician checked it out and needs my truck for at least 4 hours to connect a temporary antennae to the radio, and troubleshoot. To access the radio, the console supposedly has to come out! The XM antennae is on the rear of the cab, and has a short (approx. 2foot) pigtail cable, then connects to the cable that goes to the radio. Unfortunately, the headliner must come down to access the antennae and that specific connector! I'm scheduled for July 22 (next Monday). I will advise ya'll of the test results when I find out.

turbohawk
07-15-2013, 09:25 PM
The only times I've lost signal is when I was at a Sonic or under a bridge or in a parking garage. Otherwise the reception has been very "radio" like.

I too have noticed that some stations sound "tinny" compared to others and sounds like it's the compression rate that varies since it's not constantly good or bad on the same stations. Not a big deal but definitely not Hi-Fi 100% of the time. If it weren't for the Patriot channel I don't think I'd renew subscription.

Red devil
07-15-2013, 11:12 PM
Yep, probably the worst radio I've had in a vehicle period. Traded in my '10 wrangler and the sat radio was 10x's better than my '13 Laramie's. Not only is the sat reception bad, but so is the local stations. When my free subscription runs out, I'm actually considering trading in the truck.

J Roc
07-15-2013, 11:15 PM
Tree cover interrupts mine easily as well.

RedSmart
07-15-2013, 11:52 PM
I just picked up my new 2013 Ram on Saturday and noticed something strange. Some of the stations are perfectly clear while others are crackly and sound a little "tinny". I haven't listened through every channel, but my observation is that the music channels are great (Outlaw country, Lithium, etc), but when I tune to MLB Network Radio or a MLB Play by Play game, it is like you're listening to an FM station that is out of range.

Why would some stations be clear and others not? Anyone else experience this, or can someone test this?

Easy fix, just don't listen to baseball! LOL.....

I am one of those people who used to be a huge fan of the game, but "the strike" turned me off so much, that I think I've been to two games in 10 years......and that was only because the tickets were free.

Yep, probably the worst radio I've had in a vehicle period. Traded in my '10 wrangler and the sat radio was 10x's better than my '13 Laramie's. Not only is the sat reception bad, but so is the local stations. When my free subscription runs out, I'm actually considering trading in the truck.

That could turn out to be one of the most expensive SAT radio subscriptions ever?!?!

macabra11
07-16-2013, 10:49 AM
Easy fix, just don't listen to baseball! LOL.....
I am one of those people who used to be a huge fan of the game, but "the strike" turned me off so much, that I think I've been to two games in 10 years......and that was only because the tickets were free.


This is not an option. I, too, gave up on baseball years back during the second strike. I have really gotten back into it over the past few years and listening through the radio is my preferred avenue of getting my fix. I'm a big Pirates fan who lives 2,000+ miles away, so XM is a must for me. :nap:

I did an experiment last night and tuned into every station in a row. Everything sounded great on the music stations (up through stations in the 80s I think), but then sounded crackly and tinny on anything that did not play music. Then once I got up into the really high numbered stations (Sixx, Rock Hall, Latin stuff) it was clear again. But once again, only the music channels.

This makes no sense. :doh:

macabra11
07-17-2013, 10:48 AM
Update: Installed the latest update 13.19.0 last night after a couple attempts and another go a reformatting the thumb drive. Eventually I got everything to load up though. After the installation was complete I noticed my Uconnect/Apps button was gone. After panicking for a few minutes it eventually returned (and with more bars mind you)!

I did have to reinstall the Uconnect app on my phone in order to get those remote features to work again. No biggie.

The best part is that this update seems to have solved my weird siriusxm sound quality issue! Now ALL stations sound clear and rich, not just the music stations. I also noticed quicker/snappier response time when switching between satellite stations.

usmcz28
07-17-2013, 12:21 PM
Wish there was an update for the lower model radios!

tallnick
07-17-2013, 02:04 PM
I am glad that I am not the only one with this issue of poor radio connections..

Hermes1
07-17-2013, 02:29 PM
The only loss of signal I have experienced is at one particular intersection I frequently travel through in Phoenix. I loose the sat signal just prior to approaching the intersection it then returns as soon as I make my turn or pass through the intersection.

CanuckShooter
07-17-2013, 02:37 PM
Update: Installed the latest update 13.19.0 last night after a couple attempts and another go a reformatting the thumb drive. Eventually I got everything to load up though. After the installation was complete I noticed my Uconnect/Apps button was gone. After panicking for a few minutes it eventually returned (and with more bars mind you)!

I did have to reinstall the Uconnect app on my phone in order to get those remote features to work again. No biggie.

The best part is that this update seems to have solved my weird siriusxm sound quality issue! Now ALL stations sound clear and rich, not just the music stations. I also noticed quicker/snappier response time when switching between satellite stations.

Did this cure your reception issues also?? Just got my new truck on Saturday and the XM radio reception is pathetic to say the least.

macabra11
07-17-2013, 04:20 PM
Did this cure your reception issues also?? Just got my new truck on Saturday and the XM radio reception is pathetic to say the least.
I live in the desert, away from any obstructions and have not noticed any reception issues. I can have my ram in my garage and still pick up sxm stations, so that is good.

My old truck had an aftermarket XM radio and I would loose reception for a few seconds going under one overpass on the way to work. I still get the cutout with my new truck/8.4an, but it is only for a millisecond.

The sound quality is MUCH better though. No more radio broadcast through an aluminum tube! :ura1:

molina67
07-17-2013, 07:52 PM
Riding on back roads I loose reception

RedSmart
07-17-2013, 10:35 PM
Update: Installed the latest update 13.19.0 last night after a couple attempts and another go a reformatting the thumb drive. Eventually I got everything to load up though. After the installation was complete I noticed my Uconnect/Apps button was gone. After panicking for a few minutes it eventually returned (and with more bars mind you)!

I did have to reinstall the Uconnect app on my phone in order to get those remote features to work again. No biggie.

The best part is that this update seems to have solved my weird siriusxm sound quality issue! Now ALL stations sound clear and rich, not just the music stations. I also noticed quicker/snappier response time when switching between satellite stations.

Glad to hear it all worked out for you.

I think that perhaps I will take mine in and get the update done too.

CanuckShooter
07-18-2013, 12:16 AM
I live in the desert, away from any obstructions and have not noticed any reception issues. I can have my ram in my garage and still pick up sxm stations, so that is good.

My old truck had an aftermarket XM radio and I would loose reception for a few seconds going under one overpass on the way to work. I still get the cutout with my new truck/8.4an, but it is only for a millisecond.

The sound quality is MUCH better though. No more radio broadcast through an aluminum tube! :ura1:

That would make a big difference [living in the desert]..mine kicks out around buildings, going uphill on the highway with a bank on one side etc etc...it's enough to really be annoying. Thanks for the reply....I appreciate it. :-)

macabra11
07-18-2013, 10:14 AM
That would make a big difference [living in the desert]..mine kicks out around buildings, going uphill on the highway with a bank on one side etc etc...it's enough to really be annoying. Thanks for the reply....I appreciate it. :-)

I've not even had my truck a week yet, so everything I say should be taken with a grain of salt until I have had more time to really test it all out. I am going on a trip this weekend up into the mountains, so we'll see what kind of reception I get through those canyons. I'll report when I get back.:smiley_thumbs_up:

Binfordtools
07-18-2013, 06:30 PM
My first post here - too bad it's a bitchy one! I am very disappointed in my radio. The sound when it plays is strange. "Tinny" at times, muffled others. What pisses me off the most of the loss of Sirrius signal. Clear day today, get in to go home and all I get is "Acquiring Signal" that never recovers. Not the first time this has happened either. Just traded in brand-x for a Dodge and never had a single problem with my satellite radio. Even in severe clouds! Not happy, this should have been a no-brainer for Dodge to get right. Guessing they used whatever the cheapest supplier for radio components they could find at the expense of customer satisfaction.

OK, but the rest of the truck is badass.

macabra11
07-18-2013, 06:31 PM
My first post here - too bad it's a bitchy one! I am very disappointed in my radio. The sound when it plays is strange. "Tinny" at times, muffled others. What pisses me off the most of the loss of Sirrius signal. Clear day today, get in to go home and all I get is "Acquiring Signal" that never recovers. Not the first time this has happened either. Just traded in brand-x for a Dodge and never had a single problem with my satellite radio. Even in severe clouds! Not happy, this should have been a no-brainer for Dodge to get right. Guessing they used whatever the cheapest supplier for radio components they could find at the expense of customer satisfaction.

OK, but the rest of the truck is badass.
What radio and software version are you running? Updating to 13.19.0 fixed my sound quality issue.

Binfordtools
07-18-2013, 06:43 PM
What radio and software version are you running? Updating to 13.19.0 fixed my sound quality issue.

How do I tell? I have the ....umm...3.0 radio, does that sound right? It's the touch screen but the smaller one. How do I find out the software version?

macabra11
07-18-2013, 06:51 PM
How do I tell? I have the ....umm...3.0 radio, does that sound right? It's the touch screen but the smaller one. How do I find out the software version?

It's under "Settings" and then "System Information". I have the 8.4an, so I'm not positive how the 3.0 system is setup.

KJ48
07-19-2013, 01:54 AM
Just picked up a '13 with the 8.4AN radio and first thing I noticed was the sirius talk stations sounded like crap, also the FM reception is pretty bad. I also miss the current song/artist display on the preset buttons my old '12 730 radio had.

I just did the 13.15.4 update and I didnt notice much difference, guess I'll try the 13.19.0 if I can find it.

macabra11
07-19-2013, 01:07 PM
Just picked up a '13 with the 8.4AN radio and first thing I noticed was the sirius talk stations sounded like crap, also the FM reception is pretty bad. I also miss the current song/artist display on the preset buttons my old '12 730 radio had.

I just did the 13.15.4 update and I didnt notice much difference, guess I'll try the 13.19.0 if I can find it.The 13.19.0 update fixed my issue with the talk radio stations.

I am sending the 13.19.0 update file to another Ramforumz user to host for downloading. Check this thread http://www.ramforumz.com/showthread.php?t=146248 for updates when it gets loaded. :wavey:

KJ48
07-19-2013, 01:43 PM
The 13.19.0 update fixed my issue with the talk radio stations.

I am sending the 13.19.0 update file to another Ramforumz user to host for downloading. Check this thread http://www.ramforumz.com/showthread.php?t=146248 for updates when it gets loaded. :wavey:

Seen that thread and I'm keeping an eye out for it, thanks.

RedSmart
07-19-2013, 11:23 PM
I just had my truck into the dealer today and they gave me the most current update available.......13.15.4??

Perhaps because I am in Canada that is the most current one, or did they not grab the correct file?

I just looked online now and it also says that 13.15.4 is the most current version for my truck?? Odd, very odd?