DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > SuperiorStyles


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Conversation Between SuperiorStyles and JWJohnson822
Showing Visitor Messages 1 to 4 of 4
  1. SuperiorStyles
    11-10-2011 04:17 PM
    SuperiorStyles
    my advice is too get the top end rebuild before its too late. it would run you less money now before its too late.
  2. JWJohnson822
    11-10-2011 02:43 PM
    JWJohnson822
    Thank You for the response, I use synthetic oil, that is what i was told to use for being a truck that pulls a travel trailer, the water temp looks okay to me the only time I see it go a little over the half way mark is in the summer time when I pull the trailer up a steep incline. I here the tapping when i first start the engine and then goes to a very very low tapping. As long as i owned the truck it has never over heated. I am just worried about blowing up the engine.

    Once again THANK YOU for your time helping me with this I do not know where to turn too other then going to a mechanic.
  3. SuperiorStyles
    11-02-2011 12:09 PM
    SuperiorStyles
    Thanks JWJohnson, My advice would be to get the Valve covers off check every Valve Adjuster and Rocker Arms for any signs of wear or fresh marking like Grinds If you do not see anything and they all look well enough good then have the mechanic
    get a Camera Scope to look at every Cylinder and check for Loose Valve Seats on each Valve also a compression test would come very handy include a leak down test during compression test. I got some Questions for you that might point out whats the taping.


    What Motor Oil weight are you using ?

    What the water Temp look like at full warm up?

    When do you hear the Taping ?

    Has the truck Over heated in the 6 years? and how many time?
  4. JWJohnson822
    11-02-2011 07:32 AM
    JWJohnson822
    SuperiorStyles I hope you don't mind me posting this question to you, I am new to this forum. I have a 2003 Dodge Ram 1500 with a 4.7 v8, I bought the truck used and have been the owner for 6 years. when i hit about 100,000 mile I started to hear a what i think is a valve tap on start up. the sound does go away after a couple of minutes. Now for the question is this something I should be concerned about and have mechanic look at it. What would be your suggestion on the right rout to follow.

Advertisement






All times are GMT -4. The time now is 03:40 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum