DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > BooBear185
Register Advertising Gallery FAQ Members List Calendar Search Today's Posts Mark Forums Read


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Conversation Between BooBear185 and RedRam10
Showing Visitor Messages 1 to 3 of 3
  1. RedRam10
    07-14-2011 10:15 PM
    RedRam10
    Wish I could give you a specific answer, how about trying a post here in the correct GEN for your truck? http://www.ramforumz.com/forumdisplay.php?f=34
  2. BooBear185
    07-14-2011 11:12 AM
    BooBear185
    Hi Red....Maybe you can answer something for me..... My truck is making some funky noises in the front end. I had the brakes, rotors, calipers and hoses all replaced and also the rack and p/s pump and hoses, but it still making a LOT of noise, it's grinding crunching and groaning and it's all high pitch noises. When the mechanic replaced everything he noticed a tear in the CV boot, so I'm getting those replaced. Then I was talking to a guy at the Bloomsburg Truck Jamboree and he said it might be the bearing in the hub assembly. What do you think? Am I replacing the correct parts?
  3. RedRam10
    07-14-2011 08:36 AM
    RedRam10
    Hi and a warm Carolina welcome to the best RAM ForumZ on the web. I'm here to help you make the most of this great site.

Advertisement






All times are GMT -4. The time now is 12:18 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
vB.Sponsors