DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > ShawnC13
Register Advertising Gallery FAQ Members List Calendar Search Today's Posts Mark Forums Read


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Conversation Between ShawnC13 and wgwareham
Showing Visitor Messages 1 to 5 of 5
  1. ShawnC13
    12-02-2012 12:56 PM
    ShawnC13
    I think this maybe the wiring diagram for your Cluster just verify colours and you can make sure all grounds are checked

    Cluster Wiring
  2. ShawnC13
    12-02-2012 12:48 PM
    ShawnC13
    I am just grasping at things here with your gauges. Have you looked in the 3rd Gen Electrical Section. Did you contact the company you got the refurb'd PCM from. Sorry I am not a truck expert just enjoy having mine. I will do some more searching!
  3. wgwareham
    12-02-2012 12:27 PM
    wgwareham
    Oops let me clarify, when putting the old PCM back in the gauges are still dead, and the truck won't run like before I put the new PCM in. Its a 2002 Dodge 5.9L gas
  4. wgwareham
    12-02-2012 12:26 PM
    wgwareham
    Hey Shawn I hope you can. I had a weird problem where truck would cut out occasionally and then the gas gauge would occasionally swing to empty and the light would come on, didn't take long for the truck to no longer stay running without feathering the pedal. Assumed it was gas flow issue and replaced my fuel pump, that didn't make any difference, all same symptoms stayed. I had a 601 error on the PCM since I had it (2 years) decided to give it a shot and got a refurbed PCM. The truck runs pretty darn good now, however all my gauges are dead and some of the lights are lit. I checked a bunch of grounds and cleaned them up. If I put the old PCM back on the gauges do the same thing but truck won't run like before.

    Any troubleshooting tips on the gauges would be greatly appreciated.

    Thanks man!
  5. ShawnC13
    12-01-2012 12:48 AM
    ShawnC13
    Welcome and congrats on joining the best RAM forum on the web. If there is anything I can help you with let me know. Once again let me welcome you to the Z!
    Shawn

Advertisement






All times are GMT -4. The time now is 12:00 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
vB.Sponsors