DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Members List


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

DaveRichardson is on a distinguished road

DaveRichardson DaveRichardson is offline

Dodge Ram Forum Newcomer

Visitor Messages

Showing Visitor Messages 1 to 8 of 8
  1. RedRam10
    05-20-2011 11:35 PM
    RedRam10
  2. Toms Blue Ram 1500
    04-08-2011 09:55 PM
    Toms Blue Ram 1500
    Hey there , just checkin in to see how your doing enjoying the site . Theres a ton of information and over 23,000 members . So if theres anything you need , you can post up or shoot any of us Z staff a message and well be more than willing to help . Talk to ya soon . Tom
  3. BlueJet
    04-06-2011 10:03 PM
    BlueJet
    Your best go to person here would be RamTech, as I am completely clueless
  4. CajunDodge
    04-06-2011 05:17 PM
    CajunDodge
    Welcome to RamForumZ! Feel free to PM me or you can leave a message on my profile page: http://www.ramforumz.com/member.php?u=842 if you need any help!

    - Cajun
  5. RedRam10
    04-06-2011 11:50 AM
    RedRam10
    Hi Dave, a big HELLO and a warm Carolina Welcome! I'm sure you'll be enjoying all the ForumZ has to offer! I'm out looking for friendZ with a common interest; TRUCKS!
  6. brad12kx
    04-06-2011 10:38 AM
    brad12kx
    Great to have you here. Hope to see you around the forum.
  7. DaveRichardson
    04-06-2011 10:25 AM
    DaveRichardson
    I join in hopes of getting an answer to an issue I have been having with my 2001 Dodge Ram 1500. When putting my truck into 4WD, it acts like just the passenger side is engaging and seems like it's in 4L and not in 4H. When its engaged, there is also some weird whining sound's, almost like dry gears but the transfer case is full of oil. When it comes out of 4WD theres a big clunk sound then it's fine. Sometimes I also have to put it in reverse and back up a few feet to get the 4WD to disengage.
    Last year I had the tranny rebuilt, had the transmission tech check the transfer case while everything was apart, he said there was nothing wrong and that everything looked good. He change one universal joint and as of right now, all joints are in great shape, no play and all tight. Could the actuator be causing this issue? Im not sure how the front end would act if the actuator goes bad. Any information you could give me would be greatly appreciated.
    Dave
  8. BlueJet
    04-06-2011 09:49 AM
    BlueJet
    Welcome to the Z family! If you have any questions or need help with anything feel free to ask!

About Me

  • About DaveRichardson
    Location
    Maine
    Gender
    Male
    Real Name?
    David Richardson
  • VEHICLE INFO
    Enter your vehicle info here!
    Vehicle
    2001 Dodge Ram 1500 SLT
    Trim Level
    Larmie SLT
    Color
    Maroon
    Engine
    1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 04-08-2011 12:31 PM
  • Join Date: 04-06-2011
  • Referrals: 0

Friends

Showing Friends 1 to 1 of 1
  • RedRam10
    • RedRam10
    • Dodge Ram Forum Senior Member!
    • RedRam10 is offline

Advertisement






All times are GMT -4. The time now is 09:05 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum