DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Members List
Register Advertising Gallery FAQ Members List Calendar Search Today's Posts Mark Forums Read


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Lambicr is on a distinguished road

Lambicr Lambicr is offline

Dodge Ram Forum Newcomer

Visitor Messages

Showing Visitor Messages 1 to 3 of 3
  1. Lambicr
    04-09-2013 08:16 PM
    Lambicr
    Just removed air cleaner, alternator, changed out one of the plastic vacuum hoses that runs to the valve on top of the air pump. Changed the PVC valve and grommet. Cleaned things up, put it all back and now it is running at very high idle....did I miss a vacuum hose on the throttle body?
  2. Chunkem
    04-01-2013 07:39 PM
    Chunkem
    Hello and welcome to the forum, we would like to hear from you! Drop me a message if you have any questions and please stop by the newbie section found here and introduce yourself...If you have any pics of your ride please feel free to post them when you introduce yourself......See you on the boards!
    ED
  3. CajunDodge
    04-01-2013 11:00 AM
    CajunDodge
    Welcome to RamForumZ! Feel free to PM me or you can click on my name to leave a message on my profile page if you need any help!

    - Cajun

About Me

  • About Lambicr
    Gender
    Male
  • VEHICLE INFO
    Enter your vehicle info here!
    Vehicle
    1989 Ram W150
    Color
    Originally Twilight Blue Pearl Metallic
    Engine
    1988-1991 318ci (5.2L) LA V8 140hp

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 05-19-2013 03:26 PM
  • Join Date: 03-31-2013
  • Referrals: 0

Advertisement






All times are GMT -4. The time now is 06:04 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
vB.Sponsors