DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   Cummins Diesel Specific Topics (http://www.ramforumz.com/forumdisplay.php?f=163)
-   -   no power (http://www.ramforumz.com/showthread.php?t=102259)

126happy 01-22-2012 10:34 PM

no power
 
ok im new to the ram with the 5.9. i have a 04 1/2 3500 dually so bare with me on the tech wording lol. ok i had this problem going on a trip last week moving a trl but it went away when i shut the truck off over night. it seems like its running in safe mode( limited power) and its getting crappy fuel milage like 7.8 pulling a 7500lbs trl. last time the check engine light came on but not this time. i had the codes cleared last time also and the codes were saying air intake sensor( something like that). now if the computer rest that last week and the problem is back my question is should i replace the sensor on the air box or am i wasting $$???

brad12kx 01-27-2012 02:22 AM

If an intake air sensor is not working properly, the computer will do some interesting things. If it's the IAT (Intake Air Temperature) sensor, then I would just buy one. They are less expensive than the fuel to pick one up....or at least should be. While your in that area, take a real good look at the are filter element and intake pipes to the filter. Any blockage here will have very negative results. :4-dontknow:


All times are GMT -4. The time now is 04:36 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger