DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   2011 Dodge Ram Forum (http://www.ramforumz.com/forumdisplay.php?f=117)
-   -   CheckEngine light on and no ECO (http://www.ramforumz.com/showthread.php?t=109122)

Ramajama 04-02-2012 12:07 PM

CheckEngine light on and no ECO
 
Took our first road trip in the RAM this past weekend. It was about a 2 hour drive to the lake and it went well. The only thing I did "out of the norm" was turn on the tow/haul mode when I got into the hilly/twisties, which made it a joy to drive. The next day, the check engine light came on. While the light was on, I noticed that the ECO never came on. After dinner, the light went out and ECO would activate. Then the next day on the drive home that CE light was on for the entire trip and ECO never came on. Obviously theres some connection between the two....but its back to the dealership...AGAIN. :smiledown:

Anyone had this problem pop up?

Arth 04-02-2012 12:12 PM

On my 2009 when my check engine light popped on because I had a loose gas cap the "Fuel Saver" icon never appeared but I know it will dropped down to 4 Cylinders because I could hear it thanks to my flowmaster exhaust. I don't know why but if the CE is on the computer just does some funny stuff...

JasonRB2k1 04-02-2012 01:17 PM

it seems like every saturday night my CEL comes on for slow response from o2 sensor, at that pointl I lose my ECO until it turns off the next afternoon.

huntergreen 04-02-2012 02:34 PM

sounds like a trip to the dealer. wonder what they will say?

Ramajama 04-02-2012 05:49 PM

Going in the morning. I'll see what codes are showing up...

Ramajama 04-07-2012 09:42 PM

I took the truck in. They are replacing the door lock switch and replacing the fuel sending unit....they supossedly replaced that the second time I had it in the shop for the fuel gauge problem. Hopefully three times is a charm. They say that the code that showed up for the check engine light was from the fuel sending unit malfunction. Which kind of makes sense because instead of the fuel gauge just constantly not reading right it was starting to jump around, it would go from full to empty, then back up to half full, then down to empty and back up to a three quarters, etc...so it was really messed up.

Oh well, we'll see.

huntergreen 04-09-2012 01:44 AM

hopefully they will get it fixed this time in.

jc4041 04-09-2012 03:48 AM

I don't get an ECO light in my '09....but like Arth, I don't need a light with my exhaust lol


All times are GMT -4. The time now is 12:31 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger