DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   Cummins Diesel Specific Topics (http://www.ramforumz.com/forumdisplay.php?f=163)
-   -   Speedo/odo issue (http://www.ramforumz.com/showthread.php?t=111701)

Miami Son 05-01-2012 01:08 PM

Speedo/odo issue
 
Hi guys, got a 1990 D350 with about 115k miles on her. The speedo works fine, but the odometer stopped working awhile back. Since there's no cable driving the two and the speedo works what should I look for? Is it likely something in the gauge cluster and is it fixable or should I look for a replacement? Any help appreciated.:smileup:

Warlock III 06-13-2012 10:53 PM

Done and done. Look for another. As the speedo turns it also spins the odometer. As they wear sometimes the gear goes and stops counting. I was going to say it's a matter of mileage as opposed to age...but that's not entirely accurate since different climate conditions (Death Valley)have different effects on the original lubrication.

Kinda like putting new brakes on your truck and then driving cross-country the next day non stop. Some might say that their brakes have 5000 miles on them when they actually probably have about a half mile on 'em.

If you want to save some time, try Car-Part.com. It's a used parts locator that checks (inventoried) stock in scrap yards on the Hollander and Pinnacle system used between scrap/recycling yards.

Oldy but goodie 08-28-2012 10:14 PM

I was working on mine but it was a different issue. Mine works when it wants to. The oerdrive goes away at the same time. Since the speedo is electric speedo so I have an idea what and where but time to get to it. WarlockIII I like your stepside body.
Where steal it from???? Ha Ha.

hemiram66 10-01-2012 01:31 PM

There are two gears that are your problem. You can get those here:
http://www.odometergears.com/product...ept+Monaco/125
There are probably some guys on other forums who did an install but i guess Youtube also works:
http://www.youtube.com/watch?v=rVHSufDAzRo

Oldy, your odometer motor is probably going. Ask around diesel truck resource or check ebay to see if you can get one

1993 ram 150 11-20-2012 12:15 AM

Speedo / odometer issues
 
I have just the opposite problem. My trip and odometer work fine, but speedometer is inop. no jumping, just reads super slow ( going 70 using my gps, speedo may say 12.5 ) or stays at 0. any one have any ideas? mines a 93 with a 5.2 gas motor automatic. :4-dontknow:

Gen1dak 11-20-2012 04:10 PM

Ooops, wrong thread. Posted reply. my goof.

marnell79 11-23-2012 01:44 PM

check the ratio drive adaptor its right off the trans the problem is the shaft wears out and it stops or you have a bouncing speedo or it reads really slow. I took mine out and just screwed the speedo sender straight into the trans and It starting working again problem is now it reads 87mph at 55. so its pretty far off and finding one is no easy task. Ive looked on-line and at the dealer (who have no clue)


All times are GMT -4. The time now is 04:39 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger