DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   5.7L (345 cu in) HEMI V8 Specific Topics (http://www.ramforumz.com/forumdisplay.php?f=196)
-   -   Transmission problem (http://www.ramforumz.com/showthread.php?t=114810)

FDBDW 06-12-2012 03:09 PM

Transmission problem
 
This morning I put my truck in reverse to leave for work and the heads up display showed I was in manual 4th. I tried taking it out of manual mode and it wouldn't change from 4th,then I tried shifting thru P, R, N went back to drive and it still was in fourth. And it didn't just read 4th. It was actually in 4th. I could barly get going from a stop. I shut everything down and re-started it, after that everything was normal. Anyone experience this or have any idea why it happened.

moparornocar72 06-12-2012 03:32 PM

how quickly did u shift down to reverse after start up??

snrusnak 06-12-2012 03:39 PM

I may be wrong but I think that might be "limp mode". Wait to see what transengineer says...

FDBDW 06-12-2012 05:00 PM

Quote:

Originally Posted by moparornocar72 (Post 819447)
how quickly did u shift down to reverse after start up??

I think pretty quick, I remember the truck kinda jumpin

Studbuster 06-14-2012 11:55 PM

I had this same problem with mine starting at 12,000 miles. Had it to the dealer many times with them trying to repair by throwing parts in it.

For my protection, I filed under the Florida Lemon Law. When the dealer ran out of ideas, they contacted the Star Hotline. My dealer finally fixed it at 25,000 miles.

You MUST get it to the dealer when locked in 4th (really 3rd gear) and don't shut it off until they run a computer check on it, they will never find any codes after the computer clears at shut off.

Have your dealer PM me and I'll give them my Vin to check the records of the tries my dealer made to fix this PITA. It is not normal and can be fixed. I'm now at 40,000 miles.

Good Luck

CHVYKLR 06-19-2012 09:08 AM

Quote:

Originally Posted by Studbuster (Post 821284)
My dealer finally fixed it at 25,000 miles.

what did they fix?

frickenbored 06-21-2012 10:09 PM

Good possibility you need a new shifter assembly, I see similar problems with chrysler minivan shifters and grand cherokee shifters. Haven't really seen any ram shifter problems though...

If your pcm has stored any codes they are stored there untill they are erased with a scan tool so turning the truck off will not erase the codes. Also make sure you didn't accidently put it into autostick mode by moving the shifter from side to side while in drive. I can't tell you how many times people come into the dealer complaining that they are getting bad mileage and the trans isn't shifting because they are in autostick mode and have no clue. I really wish Chrysler would have added another detent that you would have to shift into to get to autostick.

FDBDW 06-22-2012 01:12 PM

Quote:

Originally Posted by frickenbored (Post 826518)
Good possibility you need a new shifter assembly, I see similar problems with chrysler minivan shifters and grand cherokee shifters. Haven't really seen any ram shifter problems though...

If your pcm has stored any codes they are stored there untill they are erased with a scan tool so turning the truck off will not erase the codes. Also make sure you didn't accidently put it into autostick mode by moving the shifter from side to side while in drive. I can't tell you how many times people come into the dealer complaining that they are getting bad mileage and the trans isn't shifting because they are in autostick mode and have no clue. I really wish Chrysler would have added another detent that you would have to shift into to get to autostick.

I dont have my Diablo anymore so I will have to take it by the dealer to see if there is a code stored. I know for sure it wasnt in manual shift mode, that was my first thought when it happend so I tried shifting it up and down manualy and it was stuck in 4th. Not only on the display but the trani to, while driving it wouldnt shift up or down. It would barly move from a stop cause it was lugging so bad being in 4th from a dead stop

frickenbored 06-22-2012 11:22 PM

I was thinking maybe a TRS (trans range sensor) but if it was actually stuck in fourth gear it's most likely a little deeper in the trans. All chrsyler transmission use solenoid packs, its what actually controls the shifting of the trans instead of a overly complicated valve body like in the old days. Chrysler transmissions are notorious for bad solenoid packs, i can't even count how many I've replaced at work. Sounds like you either have a bad solenoid or bad wiring for the solenoid pack. Either way it should have a code stored.

Studbuster 06-29-2012 10:25 PM

This is what the dealer did to mine over 13,000 miles. Many trips to dealer.
1- solenoid switch
2- valve body assembly
3- powertrain control module
4- tranduce-pressure sensor
5- had for five days, could not duplicate
6- pump kit & filters
So far so good.


All times are GMT -4. The time now is 08:36 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger