DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   4.7L PowerTech V8 Specific Topics (http://www.ramforumz.com/forumdisplay.php?f=205)
-   -   rpm cycles in park (http://www.ramforumz.com/showthread.php?t=120421)

kenstauss 08-29-2012 11:56 AM

rpm cycles in park
 
My problem seems to be when i put the truck in park.
It's got a poweraid cold air breather and throttle body spacer(came with the truck)
I've replaced the map sensor and tested the tps sensor (voltages) and iac valve (mechanically it's fine).
the rpm's will typically go from around 700 to 1200 then back to 700 and it will do that for about 10x's unless i give it gas then it goes back to around 700-800 rpm's.
i had one instance where it was cycling when i left the truck running and came back and it had shut off.
It doesn't do it all the time and replacing the map sensor seemed to help but it's done it 2x since (replaced map sensor saturday).
Any help is greatly appreciated.:4-dontknow:

goatman65 08-31-2012 01:32 AM

test the tps.. then replace it
 
I noticed a surging while in overdrive moving down the road... was 300-400 rpm range. tesit tested good.. still had the issue.. tested the tps using an ohm meter.. looked for a SMOOTH change as the sensor was moved through the working range... cleaned and put back on.. issue remained..

Replaced the TPS and the issue went away....

Goatman


All times are GMT -4. The time now is 07:04 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger