DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   Electrical (http://www.ramforumz.com/forumdisplay.php?f=199)
-   -   2011 1500 Headlight Problems (http://www.ramforumz.com/showthread.php?t=120566)

bobbybones 08-31-2012 08:38 AM

2011 1500 Headlight Problems
 
I have had issues with the passenger headlight working off an on and it finally went out. Brought the truck to the dealer and they needed to swap out a lighting module. I had this done and all worked fine for 2 to 3 weeks and now it started again off and on working not working and now out again.

Has anyone else had this problem

Thanks in advance Bones

Chunkem 09-01-2012 01:32 AM

Let us know how you make out and please keep us updated......

gs283020 09-01-2012 08:36 AM

Had this exact problem with my 11 ram on the drivers side headlight. I took it back and same thing fixed for about 3-4 weeks. Then off and on again. Funny part was if you gave it a good tap on the side it would turn back on. Lol. After getting aggravated with 2 different trips to the dealer and them saying we cannot find anything wrong due to it working when it went in.

Anyways decided to tear into it myself and come to find out it was a loose connection at the wiring hookup from the main harness to the headlight. Made 2 simply attached the wires with spades instead of the plug and have not had an issue since. Is now going on a year without a problem.

That's what it was for me and I hope this might help you out on at least a start.

Jmac86201 04-16-2013 02:05 PM

gs283020, i am having this issue with my harness connector, just ordered a new jumper harness, hoping this fixes it, if not can you tell me how you made that wire attachment to make yours work

gs283020 04-16-2013 04:12 PM

Quote:

Originally Posted by Jmac86201 (Post 1071374)
gs283020, i am having this issue with my harness connector, just ordered a new jumper harness, hoping this fixes it, if not can you tell me how you made that wire attachment to make yours work

First I apologize if you got the response and were confused. Am actually on 2 almost identical threads regarding headlights. All I did was use a jumper wire around the main connector. You could tell which one was loose by simply wiggling each wire at the box. I used 2 inline connectors on either side of the positive feed(which was the loose wire) for my low beams connecting it around the connection box, then used 2 waterproof spades in between to make it removable if necessary.

Hope this helps. If you need anything further let me know.

Overseer54 08-20-2013 07:08 PM

I am having the same issue with my truck. I can deal with loose connections, but what box are you talking about Jmac86201? I've had the whole front of my truck apart several times trying to figure this out. The driver's side headlight will come on and then after 10 minutes or so will go out, once things cool down(my assumption) it will come on and do the same thing over and over.

dwsdad 08-21-2013 12:11 PM

I had the same issue with the drivers side low & high beams on my 2012. Turned out to be the connector on the harness that plugs into the headlight. The dealer replaced that connector and it has been fine....so far.

MXMagnum 01-03-2014 08:07 PM

Passenger side high and low beams not working - looks like this is where I will start. Marker light works, but no headlight. About a year ago I noticed the RH flickered a couple of times, had not noticed since and kinda forgot about it. Looks like the Gremlin is back.

143777 01-26-2014 05:03 PM

Just joined this forum for this exact problem. Mine started on passenger side and now has gone to the drivers side. Will take both assemblies out and look for loose wires again. Thanks!

Steve

143777 01-27-2014 06:36 PM

Is it a positive wire running to low beam and another to the high beam or one positive running to the light assembly? And why will it shift from one side to the other?

Thanks,

Steve


All times are GMT -4. The time now is 02:54 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger