DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   Exhaust (http://www.ramforumz.com/forumdisplay.php?f=145)
-   -   Flowmaster Series 10 (http://www.ramforumz.com/showthread.php?t=125061)

momo1 11-01-2012 12:49 PM

Flowmaster Series 10
 
I have a 2010 1500 with the 5.9 Hemi, It has the factory duel exhaust 3" in 2 1/2 dual out . I installed a Flowmaster series 10 muffler and left the two resonators on. Now I have what sounds like an engine sputter at low speed, if I give it a little more gas it goes away for awhile until I give it gas again and it starts all over again. I took it to two different Dodge dealers and they couldn't find anything wrong with the engine, transmission or anything else for that matter. Any ideas?

Oldskoolram 11-04-2012 08:32 AM

Well I would venture to say it may be or have something to do with the muffler. Are you sure its an engine sputter or is it an exhaust gurgle since the series 10 is a single chamber muffler. My 97 rcsb has one of these and it does seem to have a slight gurgle and very lowthrottle but when you give it the cheeses it goes away. Its only a guess,but have you taken it back to the muffler shop that installed it to make sure there were no problems?

damnkidd012 02-16-2013 05:33 PM

I think thats just the flows cuz i have 40s on my 5.9 and it does that whenever im just rolling


All times are GMT -4. The time now is 01:07 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger