DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   Cummins Diesel Specific Topics (http://www.ramforumz.com/forumdisplay.php?f=174)
-   -   lost prime overnight (http://www.ramforumz.com/showthread.php?t=125263)

Nitro1 11-03-2012 11:36 PM

lost prime overnight
 
hi all ! It happened again. fuel system lost its prime after sitting 13 hours. This time its not like last time, last year my diesel would start, run for 30 seconds then die, loosing prime. You guy told me to check pre filter fuel heater, and see if the electrical connector was wet with fuel. it was, so i added electrical grease in the plug, and it worked for about a year. tried that trick again but its not working? wonder if that should be changed? this time instead of running for 30 seconds, it just dont start. if i catch it before 8 hours she starts, a little rough but runs and drives fine. replaced fuel filter, but that didn't help. could it be closer to the injector pump. any ideas?

C Kessinger 11-23-2012 05:42 PM

I have a 98 with the 24 valve diesel. i had the same problem and found that the fuel heater was leaking while running and causing me to lose prime if i didnt start every day. my fuel heater is on top of my filter assembly and there is a small o ring that was leaking. ive heard of older heaters going out too and being deleted. there is a delete plug for it, but i found the o rings and just replaced mine today. no more leaks.


All times are GMT -4. The time now is 09:11 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger