DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   5.2L V8 Specific Topics (http://www.ramforumz.com/forumdisplay.php?f=172)
-   -   Is it the transmission or the fuses? (http://www.ramforumz.com/showthread.php?t=125995)

JMeris 11-13-2012 11:03 PM

Is it the transmission or the fuses?
 
I just bought a 96 Ram 2500. It had some sensors replaced, and I've done some fixing on the brake lights. Initially, a code showed up for the check engine light that said it was an issue with the EVAC vacuum system. I replaced a hose and the light went out. It still hesitates during acceleration and it dies at stop lights, unless I put it in Neutral. It is wired for electric trailer brakes, and the cruise control light flashes when I turn off the engine, but cruise control does not work during vehicle operation. Also, there is only a part of the factory anti-theft still on,in that I have to push a button on the alarm remote to start the truck. The alarm does not activate when the truck is off. Is this a fuse/wiring issue, or is it related to the transmission? Is the cruise control interfering somehow? Should I replace the rest of the EVAC system? What's going on? Please help. I love this truck.


All times are GMT -4. The time now is 01:50 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger