DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   3.7L PowerTech V6 Specific Topics (http://www.ramforumz.com/forumdisplay.php?f=182)
-   -   2002 Dodge Ram 3.7 Rough Idle/stalling out. (http://www.ramforumz.com/showthread.php?t=127004)

08JD 11-28-2012 03:37 PM

2002 Dodge Ram 3.7 Rough Idle/stalling out.
 
So question for you guys, or if anyone can point me in the right direction with a member who might know.

2002 dodge ram 3.7l v6 - 5speed with 148,000 miles on it.

When at a stop light, sometimes it will do it, sometimes it wont, or sometimes it will do it everytime. it will have a lower rpm idle and really idle rough. Than it will eventually stall. If i catch it before it stalls out and start driving away, i notice that when shifting from 1st gear into 2nd (with the cluch in, the rpms will continue to rise until around 3k). when stalling out it spudders and makes a knock sound.

weird huh?

Only code that im pulling is p0442, evaporative emission control system leak detected (small leak).

I have a gas cap ordered, its on its way. Also i climbed underneath the truck and checked the hoses around it, noticed that zip ties are securing them to the nipple. (stupid previous owner, im going to go ahead and do it the right way).

Now my question is, if its just the gas cap (since it doesn't seem to seal tight), would this really be causing this issue to happen with my motor?

Motor sounds great when running great, normal injector ticking, nothing else.

Please get back to me,

John

RamTech 11-28-2012 03:48 PM

The EVAP code has nothing to do with your problems. Look for a dirty throttle body and IAC motor as the source of your stalling problem and worn out spark plugs and/or carbon buildup on the intake valves for the rough running.

08JD 11-28-2012 03:52 PM

I just talked to my fiances father who was a mechanic for a while now and he said on his 2003 gmc sierra he had similar issues and complaints because of the gas cap not sealing properly.

just curious if its the same with my ram.

HemiLonestar 11-28-2012 06:59 PM

Loose gas cap may give you a code, it will NOT however cause your engine to run like shit.

08JD 11-28-2012 09:15 PM

***Update***

i decided to pull the battery off, let the truck sit for around 15 min. and reconnected it. Check engine light turned off for the evap canister leak. Hasn't came back on yet, most likely will.

But i did manage to catch a new code while it was beginning to stall out p0031 H02S Heater Control Circuit Low Bank 1 Sensor 1.

Im assuming o2 sensor, but its funny since i just changed that o2 sensor for a different code and has been fine for around 200 miles.

Faulty o2 sensor? but it ran fine with a faulty o2 sensor before...

Any advice, let me know, please.

08JD 11-28-2012 09:18 PM

if it helps, o2 sensor was bought from discount auto parts, am i better off getting mopar genuine parts? or rock auto? etc.

Looking to not hurt my engine, i still am getting good gas mileage but power sucks when trying to accelerate from a stop with a engine about to stall

Dorian1979 02-22-2014 03:53 PM

Quote:

Originally Posted by 08JD (Post 948427)
So question for you guys, or if anyone can point me in the right direction with a member who might know.

2002 dodge ram 3.7l v6 - 5speed with 148,000 miles on it.

When at a stop light, sometimes it will do it, sometimes it wont, or sometimes it will do it everytime. it will have a lower rpm idle and really idle rough. Than it will eventually stall. If i catch it before it stalls out and start driving away, i notice that when shifting from 1st gear into 2nd (with the cluch in, the rpms will continue to rise until around 3k). when stalling out it spudders and makes a knock sound.

weird huh?

Only code that im pulling is p0442, evaporative emission control system leak detected (small leak).

I have a gas cap ordered, its on its way. Also i climbed underneath the truck and checked the hoses around it, noticed that zip ties are securing them to the nipple. (stupid previous owner, im going to go ahead and do it the right way).

Now my question is, if its just the gas cap (since it doesn't seem to seal tight), would this really be causing this issue to happen with my motor?

Motor sounds great when running great, normal injector ticking, nothing else.

Please get back to me,

John

Hi, did you ever find out what was causing the rough idle and stalling out?

I have an 02 5.9 ram 1500. It is doing the same thing. Only has stalled a few times. But rough idles with the rpms going very low.. When I catch it before stall it feels like it's going to stall out with the knocking sound. I just changed the tps today, hoping that's it. But want edit I see if you ever pinpointed the issue. Thanks!

boyohboy 06-04-2014 01:22 PM

I had a Town and Country Van that began doing that and eventually would just stop running while driving. I don't remember any codes as this happened a long time ago. But eventually it turned out to be a problem with the electronic ignition system over-heating and cutting out. The other issue I had was with a throttle body wearing out causing a rich fuel problem. Lou.


All times are GMT -4. The time now is 11:35 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger