DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   5.2L V8 Specific Topics (http://www.ramforumz.com/forumdisplay.php?f=172)
-   -   CEL shows misfires but no misfire (http://www.ramforumz.com/showthread.php?t=128077)

eddie7644 12-11-2012 11:00 PM

CEL shows misfires but no misfire
 
I have a 97 1500 5.2L. The problem im having is i keep getting misfire codes, random misfire on all cylinders. There is no obvious misfire I mean I dont feel anything the truck runs great. I will clear the codes and when I get on it like merging onto a highway the CEL will flash then stay on and show all cylinders randomly misfiring. I have replaced cap, rotor, plugs, wires, crank sensor, distributor, hollowed cat. Like I said you do not feel any misfire it runs great. Any ideas would be greatly appreciated!

RamTech 12-12-2012 09:49 AM

What codes are you getting and have you replaced the intake manifold plenum pan gasket?

eddie7644 12-12-2012 11:33 PM

I am getting PO300-308. Yes I replaced the gasket I actually bought the Hughes upgrade aluminum was I also replaced the fuel pump, MAP sensor, IAC valve and TPS.

panhead 12-13-2012 12:47 AM

How many miles are on the O2 sensors? O2 sensors can create a bunch of problems.

eddie7644 12-17-2012 01:27 PM

Maybe about 50,000 on them

panhead 12-17-2012 03:56 PM

Hm, there about due but shouldnt cause a misfire. Did you make sure that the cap is screwed in tightly? Make sure none of the wires are loose and rubbing on each other.


All times are GMT -4. The time now is 06:45 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger