DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   2011 Dodge Ram Forum (http://www.ramforumz.com/forumdisplay.php?f=117)
-   -   Moisture from heater? (http://www.ramforumz.com/showthread.php?t=129022)

Dortmunder 12-25-2012 12:08 PM

Moisture from heater?
 
This doesn't happen every day, but I have noticed it a couple times.

I'll leave to drive to work, and suddenly all my windows fog up instantly. If I put the defrost on it goes away in less than a minute or so.

But this happened on the highway the other day, and I couldn't see shit while I was going about 110km/h.

It's pretty cold here now, around -15c to -30c, which probably has something to do with it, but it seems like my heater pumps out some moisture at some point.

I usually let the truck warm up for 2-5 minutes before leaving. The block heater is also plugged in and timed to go for about 2 hours before I leave.

sxthemicrewcab 12-26-2012 11:15 AM

Same thing happens to me. I have owned two different 4th generations rams and both of them do this. It only seems to happen if it is really cold and I don't warm it up for at least ten minutes.

RamSport84 01-01-2013 02:15 PM

turn on your a/c. sounds counter-intuitive but it removes the moisture from the air and will keep this from happening.

blackpearldodge 01-07-2013 02:40 PM

Quote:

Originally Posted by RamSport84 (Post 972291)
turn on your a/c. sounds counter-intuitive but it removes the moisture from the air and will keep this from happening.

The A/C in the Rams run automatically in the winter, they do so to prevent the exact problem you are describing. Perhaps your A/C unit isn't turning on (blown fuse?) I'd be having a friendly chat with my service department if I were you.

I'm having an issue right now with a mould smell on start up. In our discussion the service guy told me that the A/C unit runs momentarily to rid the system of moisture (no window frost-up).

fishinf1 01-09-2013 11:22 PM

Mine does the same thing. Sucks when you leave work and hit the freeway and bam! looking through 3 inch circle of non-fog.

Rescue1 01-10-2013 05:56 AM

It's normal, especially when the outside air vent is closed. Think about it, you are recycling moist air we breath out.. And yes the A/C Runs when you turn the defroster setting on regardless of what the LED says, most cars are this way as heat alone will not de fog the inside of the windshield....:shrk:

fishinf1 01-13-2013 11:22 PM

You would be correct on that matter, however the ac units are designed to take moisture out of the air. This is why the ac unit turns on during defrost mode. Ram Sucks on this issue. Engine heats up about as quick as a cummins and wipers freeze up quicker.

fishinf1 01-13-2013 11:27 PM

You would be correct on that matter, however the ac units are designed to take moisture out of the air. This is why the ac unit turns on during defrost mode. Ram Sucks on this issue. Engine heats up about as quick as a cummins and wipers freeze up quicker.


All times are GMT -4. The time now is 02:26 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger