DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   5.2L V8 Specific Topics (http://www.ramforumz.com/forumdisplay.php?f=161)
-   -   Heater blower stuck on top vents (http://www.ramforumz.com/showthread.php?t=129810)

Goobz 01-03-2013 05:07 PM

Heater blower stuck on top vents
 
Hey all...

Quick ?.. The heater has always functioned in my `98 1500. However, today it is stuck on the top vents, and won't change regardless of what I put the vent dial on. The temp and fan speed work, but not the vent selection.

What is HAS been doing lately, is when I gun it, or put the motor under a load, no matter what the dial setting is on, it always shifts to the defrost vents for a few seconds, then back down once I back out of it.

Any suggestions? Thanks!

RamTech 01-04-2013 08:16 AM

You have a vacuum problem. For starters, the check valve is probably bad and you may have even lost your vacuum source completely. Check the vacuum line going from the engine to the heater box for a problem.

Goobz 01-04-2013 04:11 PM

Quote:

Originally Posted by RamTech (Post 974720)
You have a vacuum problem. For starters, the check valve is probably bad and you may have even lost your vacuum source completely. Check the vacuum line going from the engine to the heater box for a problem.

I take it the vacuum line you are refering to is the one that is off the driver side of the manifold, that T's off the Cruise Control, then goes in to the firewall over by what looks like the A/C lines? That is still there.

So I would assume it is the other piece you are talking about. Where is this located, and is there an easy way to test it? :(

RamTech 01-04-2013 04:44 PM

That's the one. If you have a good vacuum supply and the line is intact, it's time to go into the dash and look for a problem there.

shot 01-07-2013 02:21 PM

What might we be looking for under there ? I replaced the radio on my 1985 and while under the dash I saw some multi-colored tubes with what looked like some OLD yellow plastic pieces hanging on them. Didn't have enough form to figure out if it was blanked off or needed to plug into something. Would this be connected with the ventilation controls? Anyone know of a schematic for that system ? thanks

RamTech 01-07-2013 02:28 PM

This is for a 1986 D150.

http://www.alldatapro.com/alldata/PR...66131/42228399

shot 01-07-2013 07:04 PM

ooooohhhhh.....there goes my Saturday. So the numbered connector block goes to the back of the control panel ? Thanks for the drawings

RamTech 01-07-2013 07:26 PM

Yeah, it should be plugged into the back of the control head.

Goobz 01-09-2013 05:09 PM

Well, everything on mine works fine. Aftermarket stereo (replaced about a year ago), heater controls for temp and speed, etc. The only thing that doesn't work is the ventilation switching.. However.. I can almost guarantee it's not the switch or connector, because if I actually select the Defrost or A/C, I can hear the compressor clutch kick in, and when I turn that function off, the compressor stops.

So I guess I'm just curious as to what piece it could possibly be...

shot 01-10-2013 02:07 PM

Hey Ram Tech........every time I come to this page a different picture appears.Did U set that up that way? I printed out the ventilation controls drawing but when I try to look at it from another pc it advances the picture. Thanks for info !


All times are GMT -4. The time now is 08:29 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger