DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   4.7L PowerTech V8 Specific Topics (http://www.ramforumz.com/forumdisplay.php?f=205)
-   -   Oil Leak (http://www.ramforumz.com/showthread.php?t=129861)

02RAMJEFF 01-04-2013 06:39 AM

Oil Leak
 
I have a leak coming from near around the oil filter. (its all gunked up underneath the engine I have to buy degresser to clean all this crap off making it harder to work underthere) anyways, I thought it might have been from jiffy lube not tightening it enough. We I tighnened it a little bit last night and I thought I fixed it so I went to wal mart and then home about 10 min drive max, checked it one more time when I got home, and it was leaking again. Its a good leak. It leaks about a drop every 5 secs. Checked the oil level yesterday too and it was still in the safe range.

Anyone know what might be leaking? Its brownish like oil so thats what I thought it was. I already think Im going to have to redo the whole oil change, maybe they didnt lube the O-ring but I hope its not that. Oh and my oil sensor wires are covered in oil. And my power steering isnt leaking anymore fixed that. So I think its near my filter. Sorry for the long read.

2002 Ram 1500 4x4
Thanks Jeff

snrusnak 01-04-2013 08:00 AM

It's somewhat common for the gasket from the oil filter to stick to the engine block when removing the old filter. Sometimes people don't realize it then install a new filter and you then have two gaskets. This will cause a leak every time.

RamTech 01-04-2013 08:39 AM

Since the sending unit wires are covered, it could be the sending unit itself. They're known to leak from time to time.

02RAMJEFF 01-09-2013 06:54 AM

Well thank you for your help guys, It was my sending unit fixed it the other day and put in amsoil 10w 30. Drove it yesterday and my oil pressure pinged again and kept pingging. Checked the oil its good, a little full but good. and It is not leaking from what I can tell.

Ran a test were you press the odometer reset, and turn the key to on. well these codes popped up any idea?
C Code
26 01
41 73
00 00

02RAMJEFF 01-10-2013 04:41 PM

Bump and also where can I get the connector that plugs into the oil sensor?


All times are GMT -4. The time now is 12:20 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger