DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   Dodge Ram General Discussion (http://www.ramforumz.com/forumdisplay.php?f=10)
-   -   Seeking Help (http://www.ramforumz.com/showthread.php?t=135433)

confuseddodge 03-06-2013 01:28 AM

Seeking Help
 
Hey -

I have a 1999 dodge ram 1500 2wd with a 5.2L engine that looses power as it goes up a SMALL incline, and it feels as though it is pulling a fully loaded car hauler even when it is towing an empty lawnmower trailer. I have tried the things listed below, but there hasn't been any improvement. Any help/ideas will be appreciated.

Things I've tried:
new wires
new plugs
new coil pack
new distributor cap
new rotor
removed and cleaned fuel injectors
checked fuel pressure (twice)
replaced solenoids in bottom of transmission
replaced transmission fluid and filter
replaced rearend with one that has a lower gear ratio
removed catalyitc converter
had the truck checked twice for engine codes - none present

GTyankee 03-06-2013 01:35 AM

some members have answered on your other post

dodge man 03-06-2013 02:40 PM

As someone said in another post, they are known for having a leaking intake manifold gasket.

NBCarbone 03-11-2013 01:08 AM

you may want to do a compression check and also when was the last time the transmission was checked / had an oil change / change filter if it's an auto?


All times are GMT -4. The time now is 01:09 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger