DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   5.9L V8 Specific Topics (http://www.ramforumz.com/forumdisplay.php?f=173)
-   -   Need Expert Advice (http://www.ramforumz.com/showthread.php?t=135689)

ninjalogic 03-08-2013 07:14 PM

Need Expert Advice
 
Hello guys and gals, here is my problem, my truck still runs rough as hell I have changed out, the IAC, TPS, and MAP sensors, I have also changed the Plugs with Champion Copper 436 Plugs gapped to 40, The wires with ACCEL Extreme 9000, Cap and rotor both ACCEL, Ignition Coil ACCEL, K&N Cold Air Intake, and changed out the Fuel Injectors

This truck did run right for about 10 minutes then went back to running like crap it Idles around right at 600 and if i lightly tap the throttle it drops almost to 450 and sometimes almost to point of stalling out, if i punch it, it will hesitate for half a second.

I am at a loss for words on this and its getting really frustrating especially since i have dumped almost $600 in parts, I did all labor myself and have even had the engines intake checked professionally for leaking plenum and its solid.

At this point I don't know what to do left, the only thing else that is original is the cats and oxygen sensors, if any Ram mechanic or RAM ASE certified mechanic can tell me what I should do at this point that would be great.

PS I have also Hard reset the truck too, unplug battery and turn key for 1 minute, again thanks guys and gals

brandonjansen 03-08-2013 07:29 PM

Quote:

Originally Posted by ninjalogic (Post 1033388)
Hello guys and gals, here is my problem, my truck still runs rough as hell I have changed out, the IAC, TPS, and MAP sensors, I have also changed the Plugs with Champion Copper 436 Plugs gapped to 40, The wires with ACCEL Extreme 9000, Cap and rotor both ACCEL, Ignition Coil ACCEL, K&N Cold Air Intake, and changed out the Fuel Injectors

This truck did run right for about 10 minutes then went back to running like crap it Idles around right at 600 and if i lightly tap the throttle it drops almost to 450 and sometimes almost to point of stalling out, if i punch it, it will hesitate for half a second.

I am at a loss for words on this and its getting really frustrating especially since i have dumped almost $600 in parts, I did all labor myself and have even had the engines intake checked professionally for leaking plenum and its solid.

At this point I don't know what to do left, the only thing else that is original is the cats and oxygen sensors, if any Ram mechanic or RAM ASE certified mechanic can tell me what I should do at this point that would be great.

PS I have also Hard reset the truck too, unplug battery and turn key for 1 minute, again thanks guys and gals

You didn't list the MAF sensor. That would be my best guess if you haven't done it. If the computer doesn't sense that there's actually air flowing into the engine then it won't want to give it fuel.

An O2 sensor shouldn't make it run bad like that. It would just run rich or lean.... Are no DTC's showing up? And have you checked the fuel pressure?

ninjalogic 03-08-2013 07:33 PM

Quote:

Originally Posted by brandonjansen (Post 1033404)
You didn't list the MAF sensor. That would be my best guess if you haven't done it. If the computer doesn't sense that there's actually air flowing into the engine then it won't want to give it fuel.

An O2 sensor shouldn't make it run bad like that. It would just run rich or lean.... Are no DTC's showing up? And have you checked the fuel pressure?


2001 Dodge ram doesnt come with a MAF sensor, If I am mistaken can you please find me a part number or link to the part, because Orielly's and Autozone don't have it listed for this truck

Yes fuel pressure running between 45 to 50 psi currently, and no DTC's yet, I reset the PCM so nothing yet, oh forgot I also changed the Cam Sensor too

brandonjansen 03-08-2013 07:42 PM

Quote:

Originally Posted by ninjalogic (Post 1033409)
2001 Dodge ram doesnt come with a MAF sensor, If I am mistaken can you please find me a part number or link to the part, because Orielly's and Autozone don't have it listed for this truck

Yes fuel pressure running between 45 to 50 psi currently, and no DTC's yet, I reset the PCM so nothing yet, oh forgot I also changed the Cam Sensor too

Hmm... well I'm stumped then.... Hopefully someone else with a 2001 will be able to chime in for you. Good luck in getting the problem solved.

ninjalogic 03-09-2013 05:42 PM

Quote:

Originally Posted by brandonjansen (Post 1033418)
Hmm... well I'm stumped then.... Hopefully someone else with a 2001 will be able to chime in for you. Good luck in getting the problem solved.

No worries, and thanks for your input :) I imagine it will eventually get solved even if i have to take it to a dodge dealership, but that's worst case scenario

MACKEYAUTOREPAIR 03-12-2013 07:53 PM

Take it to a good shop that has a Motorvac machine. I have fixed more than I can recall by doing this. The 5.2, 5.9, and the V10 of that gen respond to it better that any I have ever seen.

ramfam 03-12-2013 09:14 PM

Well one thing I've seen happen with gm is air temp sensor goes bad or cracks, it will send no sig or false sig to computer about the temp of air comeing into intake and in some cases it will act like mass air inside manifold and won't always set cel ether. You do know you can check for codes without scanner on a 01 by turning key on and off 3 times and after 3rd time leave in on position code will show up odomitor screen. Be fast though they flash by quick.

ramfam 03-12-2013 09:22 PM

Auto zone part #is su3036 air charge sensor. It is located behind alt in intake rail for cyl 2.

ninjalogic 03-15-2013 11:22 AM

I would like to thank you all for your help and suggestions, unfortunately I had to bring it to a shop and according to my mechanic that works on my cars he did every test and it all comes down to the intake valve for number 6 not working correctly that it is not seating properly, so they have to take the heads off and have them rebuilt, and will cost me $1700 all this to pass California smog but on the flip side it will be completely solid and will last me a very long time, ever since i bought the truck it has given me nothing but headaches, first the tires. then the transmission going out, now this I have invested now over $10k but at least it I will take care of it and I always use full synthetic so it should last me years and years, now I can never sell it and get my money back invested but I will have a rock solid truck that I will have to just keep upgrading and putting more Mopar performance parts into it, I'm talking performance everything but not to much where i would take it to a track and race it all the time, but turn her into a very nice show truck where people with admire it.... Mopar or no car for life!!

ccd1977 03-20-2013 08:20 AM

Quote:

Originally Posted by ninjalogic (Post 1033409)
2001 Dodge ram doesnt come with a MAF sensor, If I am mistaken can you please find me a part number or link to the part, because Orielly's and Autozone don't have it listed for this truck

Yes fuel pressure running between 45 to 50 psi currently, and no DTC's yet, I reset the PCM so nothing yet, oh forgot I also changed the Cam Sensor too

No MAF sensor but it does have a MAP sensor. use the BWD brand or OEM.

Part No. EC1688 from Advanced Auto Parts.


All times are GMT -4. The time now is 12:06 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger