DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   5.2L V8 Specific Topics (http://www.ramforumz.com/forumdisplay.php?f=172)
-   -   acceleration problems (http://www.ramforumz.com/showthread.php?t=138620)

BadBonz 04-06-2013 09:31 PM

acceleration problems
 
Hello everyone, I am very excited to have found this site. Yes, I am a newbie, but a mopar nut.I am having a tuff time navigating this site,any tips will be very helpful.Now on a more serious note I need some direction.I am the proud owner of a 2nd. generation 2 wheel drive Red Dodge Ram Sport with the 5.2 Litre engine. It has a new engine control module,exhaust,cold air intake,ring and pinion gears,cat. converter,battery,for. and aft o2 censors and breaks.I purchased the ram from a one owner,(an older fellow who took very good care or it).When I start it,she fires right up,idles like a dream,no misses,spits or sputtering.When I put into gear, drive or reverse, she spits and sputters with serious attitude.I've owned her for the last eight years and have done all the labor myself.(except programming the ECM.Hopefully some of my new found friends can point me in the right direction.I'm loosin it:att:Badbonz

igotit 04-06-2013 10:20 PM

my 98 was laid up for about 2 years when I bought it.it fired up beautiful,once in gear,sputters bad...almost full throttle to maintain a low ruff idle.determined bad gas....cleared up after 2 hours running in park,reving throttle...letting idle...ect.
was your truck left parked for awhile?


All times are GMT -4. The time now is 07:59 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger