DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   Electrical (http://www.ramforumz.com/forumdisplay.php?f=188)
-   -   engine malfunction light (http://www.ramforumz.com/showthread.php?t=140736)

hammerhead123 04-28-2013 06:16 PM

engine malfunction light
 
hmm, the engine malfunction light came on the other day. I let it go for a few miles and then reset my time elapse clock on the information panel. This caused the warning light to go off??? Normal??? or should I take it in and have a computer check it out?

BTW the time elapse clock was over 99hr and coming on the 100hr mark

RansRAM 04-28-2013 06:46 PM

The one should have nothing to do with the other. The MIL was set by a detected fault and even though it went off the code should still be in there. I would at least have the system scanned to retrieve the code.

hammerhead123 04-28-2013 07:30 PM

hmm, just weird how it went off when I reset the run time-don't think it has anything to do with general maintance???

hammerhead123 04-29-2013 06:36 PM

well I went down the road and had them put a computer on it...said the computer was detecting a malfunction with the turbo

never effected the performance and the light is off now, so they said if it happens again to have it serviced...weird

as for the light going off when I reset the hour counter-they said that was probably just coincidence

RansRAM 04-30-2013 12:12 AM

Just curious what engine you have that's got a turbo ? Got to agree that it was just a weird coincidence with the hour reset and the MIL light going on.

hammerhead123 06-09-2013 07:28 PM

well the light came back on-they put a computer on it
message read turbo charger booster not pressurizing???

it still runs fine-possibly a bad sensor???

hammerhead123 06-09-2013 07:29 PM

Quote:

Originally Posted by RansRAM (Post 1084630)
Just curious what engine you have that's got a turbo ? Got to agree that it was just a weird coincidence with the hour reset and the MIL light going on.

6.7 Cummins........

hammerhead123 06-09-2013 08:53 PM

a buddy of mine just told me that I might want to try cleaning the senors...does anyone have a video of how to do this?

hammerhead123 06-09-2013 09:25 PM

well I just did the same thing as last time, turned the key to the start position and did not crank the motor-however, I reset the overhead run time clock and this turned the check engine light off

hammerhead123 06-18-2013 12:16 AM

bump any ideas?


All times are GMT -4. The time now is 12:59 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger