DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   Custom Dodge Ram Performance Mods - Engine - 5.7 HEMI V8 (http://www.ramforumz.com/forumdisplay.php?f=83)
-   -   My 0-60 time (http://www.ramforumz.com/showthread.php?t=141417)

TORMENTOR 05-06-2013 06:32 AM

My 0-60 time
 
So I went out tonight and ran a few 0-60 runs. My only mods are a K&N drop in filter, magnaflow 14" with a hemifever 91 tune.

My average was 6.4 seconds after several runs.

My truck is a 4x4 crew cab with 3.55 gears and 305/55/20 cooper zeons, heavy tires.

Is this ok?

BC18471 05-06-2013 04:20 PM

I think that is good especially since you have the 3.55's. I have the same mods, but with the 3.92's average just over 6.2.

BlackRamHemi 05-06-2013 04:50 PM

Not too bad for a Crew,

My Reg Cab 4x4 (about -400lbs lighter), is right around 5.0 seconds
also running heavy stock 20's and 305/50R20 Terra Grapplers
...same crappy 3.55 gears

Nothing beats a good Torque Converter for getting a good launch.

http://i1097.photobucket.com/albums/...aHemi/0-60.jpg

RAM EM 05-06-2013 05:27 PM

I'm running about the same, 2wd qc w/ 305/45-22s and 3.55's. I wouldn't take the DS times as gospel, more like a good guesstimation. Take it to the track if you really want to know what it will do.

BlackRamHemi 05-06-2013 06:45 PM

Quote:

Originally Posted by RAM EM (Post 1090883)
I'm running about the same, 2wd qc w/ 305/45-22s and 3.55's. I wouldn't take the DS times as gospel, more like a good guesstimation. Take it to the track if you really want to know what it will do.

LOL, I believe I have that covered bud , the local track is my second home
I've had over 200 passes over the past three years ;)
60 foot times in the 1.8's no problem

I launch in AWD (4WD Auto) so there is no tire spin, my Diablo numbers all check out fine compared to my track slips.


http://i1097.photobucket.com/albums/...aceDay/004.jpg


http://i966.photobucket.com/albums/a...t/IMG_1738.jpg

http://i966.photobucket.com/albums/a...er/Cobra-1.jpg

First 13 sec slip from 2 years ago, before I swapped in a 3000 stall Edge TC (2500' DA)
http://i966.photobucket.com/albums/a...r/13secrun.jpg

http://i966.photobucket.com/albums/a...eeper/1401.jpg

after 3k Stall ....1.8's

http://i1097.photobucket.com/albums/...timeslip01.jpg

1.874 second 60 footer Works out to a 5.01 0-60 on this 1/8th mile to 0-60 calculator
http://www.wallaceracing.com/0-60_equation.php

RamMan86 05-06-2013 06:58 PM

^ That's a sharp lookin truck

Moose612 05-06-2013 06:59 PM

Sigh I hate El paso. my qc 4x4 can barely hit 7.5 with Just about every bolt on available. tuner, vararam, fastman tb, 180stat, jba headers, magnaflow y-pipe and cat-back and most recently a qtp cutout. Granted I am working on working out the tweaks in my tune.

Redhemi03 05-08-2013 05:53 PM

Which muffler do you have on that magnaflow cat back blackramhemi? The 22"? Or is the 14 or 18?

Unfairkickazz93 05-08-2013 05:57 PM

Quote:

Originally Posted by BlackRamHemi (Post 1090845)
Not too bad for a Crew,

My Reg Cab 4x4 (about -400lbs lighter), is right around 5.0 seconds
also running heavy stock 20's and 305/50R20 Terra Grapplers
...same crappy 3.55 gears

Nothing beats a good Torque Converter for getting a good launch.

Oh wow! That is a good time!. Is that with your drag radials?

BlackRamHemi 05-08-2013 06:21 PM

Quote:

Originally Posted by Redhemi03 (Post 1092992)
Which muffler do you have on that magnaflow cat back blackramhemi? The 22"? Or is the 14 or 18?

Maggy CatBack 16869 came with a 22" muffler

<click pic for video link>
http://i966.photobucket.com/albums/a...deo/th_002.jpg



Quote:

Originally Posted by Unfairkickazz93 (Post 1092998)
Oh wow! That is a good time!. Is that with your drag radials?

The times on the Trinity display are on Grapplers , track slips on Drag Radials.
bet she'll hit high 4's on my DR's in 4wd full throttle launch if it hooks well on good pavement.

I cant stress enough how important a good Torque Converter is for cutting your 0-60 times (mines a 3000)
But then traction becomes a major issue unless you have sticky tires and smooth hot pavement.

If I dont have my truck in AWD mode (4-auto) this is what often happens when I try to launch at full throttle:

<click pic for launch video>
http://i966.photobucket.com/albums/a...o/th_003-1.jpg


All times are GMT -4. The time now is 10:56 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger