DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   Heating & Cooling (http://www.ramforumz.com/forumdisplay.php?f=201)
-   -   Bad smell = BIG warranty issue!! (http://www.ramforumz.com/showthread.php?t=141837)

Rodo 05-09-2013 11:50 PM

Bad smell = BIG warranty issue!!
 
I bought my wife a new truck (2013 Ram 1500 Penstar 1500 4x4), and she was complaining about a a bad smell when it was at idle. I just figured it was a"new pickup smell" that would eventually wear off. Fast forward 2 months and 5000 miles and it is still there. I take it by the dealership thinking they could figure it out pretty quick, but they want to keep it overnight. I get a call from them today and they say it is out of commission for at least 2 weeks while every one of the rubber hoses in the truck are being replaced...every one!!! They said it has to do with a chemical reaction between the hoses and anti-freeze and that it is a known issue by Chrysler. Has anyone else heard of this?

Trapper-db 05-09-2013 11:58 PM

Quote:

Originally Posted by Rodo (Post 1094395)
I bought my wife a new truck (2013 Ram 1500 Penstar 1500 4x4), and she was complaining about a a bad smell when it was at idle. I just figured it was a"new pickup smell" that would eventually wear off. Fast forward 2 months and 5000 miles and it is still there. I take it by the dealership thinking they could figure it out pretty quick, but they want to keep it overnight. I get a call from them today and they say it is out of commission for at least 2 weeks while every one of the rubber hoses in the truck are being replaced...every one!!! They said it has to do with a chemical reaction between the hoses and anti-freeze and that it is a known issue by Chrysler. Has anyone else heard of this?

UH NO, I call Bull S*&T

RBRK 05-10-2013 12:50 AM

Mine stinks. I keep trying to figure it out. I actually think it is the radiator hoses too. It smells like Chinese rubber like when you get something at harbor freight tools that is made of rubber. I thought I was crazy but I guess not. I think it may be more the radiator hoses mainly. Interesting.

Rodo 05-10-2013 12:51 AM

BS on what? This is not BS...I don't have a reason to make this up. So, has anyone else heard of an issue like this?

the persuader 05-10-2013 12:52 AM

Quote:

Originally Posted by Rodo (Post 1094425)
BS on what? This is not BS...I don't have a reason to make this up. So, has anyone else heard of an issue like this?

He was talking about the dealer, not you. :smileup:

RBRK 05-10-2013 12:58 AM

I've not heard of it but I have been a dealership tech for 25 years and I know my hoses smell like ass. At idle it gets picked up from the air inlet and stinks in the cab. I opened the hood and keep smelling around. The radiator hoses stink. I actually tried cleaning them hoping it will stop the smell, it still there. My truck is a month old and it started a few weeks ago. I've had a 09' 11' and now a 13' I can't believe how they can screw crap up. It's a freaking radiator hose!

Rodo 05-10-2013 12:58 AM

RBRK, like you, I thought I was smelling it around the hose at the top of the radiator...I opened the reservoir, and it smelled like normal, when the tech popped the cap on the radiator, we both about puked. He thought that maybe something had crawled inside the radiator and died at the factory. This was at the end of the day and he was going to contact Chrysler first thing this morning...that's when I got the call. They said it was going to take a week to ten days just to get the parts...back ordered maybe????

Nemmisis1 05-10-2013 07:34 AM

Quote:

Originally Posted by Trapper-db (Post 1094398)
UH NO, I call Bull S*&T


hell i secomd that.... got the 13 sport no issues AND i changed my exhaust to magnaflow 18" .... i call real bull shiat !!!!:sad:

waite waite waite...... ill open my raidiator and check..

dave6558 05-10-2013 07:38 AM

Bad smell...
 
my v6 pentastar smelled too...but it is mostly gone at 4000 miles. it was horrible up until about 2500. hoping it will all be gone in another 1000. we'll see.

Asur 05-10-2013 07:45 AM

You get a brand new truck made of Chinese recycled metal, it starts rusting the day you get it, now Chinese Rubber hoses, it just never stops, whats next. Looking forward to the day the manufacturing of everything comes back to America to be quality produced. That being said, I have no issue with my 2012, opened the Rad and only smell is that of the coolant. This can't be an isolated issue, these hoses are ordered by the thousands. Keep us posted on how this turns out.


All times are GMT -4. The time now is 01:32 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger