DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   5.2L V8 Specific Topics (http://www.ramforumz.com/forumdisplay.php?f=172)
-   -   5.2 Hard sputtering start and a bit sluggish on the move. (http://www.ramforumz.com/showthread.php?t=145344)

Darrenwood128 06-17-2013 11:50 PM

5.2 Hard sputtering start and a bit sluggish on the move.
 
Hi 5.2 engine doesnt really seem like its getting fuel when I start it from cold... spits and sputters for a couple min, will die if you push the throttle and then just comes alive and is fine... a bit sluggish when foot goes to the mat though.
Any thoughts?

Warlock III 06-18-2013 10:29 AM

Check and clean the crank position sensor on the back of the passenger's side of the engine where it meets the bell housing and see it that helps.

paintengr 06-22-2013 11:56 PM

I'll second that on the crank sensor, also think about changing the injectors with ford yellow tops from bone yard...I got a set for $40.00 smoothed out engine. And make sure your truck isn't up shifting to quickly from 1-2 trans kick down cable adjustment.

Gen1dak 06-23-2013 02:45 PM

Start with a can of Seafoam to clean out your current injectors. Assess for improvement. Again, I'm looking at the intake plenum gasket.


All times are GMT -4. The time now is 12:22 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger