DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   5.9L V8 Specific Topics (http://www.ramforumz.com/forumdisplay.php?f=173)
-   -   Need help lots of issues during cross country trip (http://www.ramforumz.com/showthread.php?t=146282)

rjmtexas75 06-28-2013 08:47 PM

Need help lots of issues during cross country trip
 
Driving form El Paso TX to Watertown NY my 99' 1500 lost overdrive the tach and stopped charging all at once while i was driving, and seems like its stuck in 3rd gear. after i stopped it wouldn't start back up the power comes on and the fuel pump come on but wont engage the starter. i did put a new alternator on it and got it to start by jumping the starter to the battery, also had to use starter fluid or it just cranks and still no charging. Got her as far as Chicago running the truck i had on the trailer and using extension cords to charge mine with the rear truck all the while stuck in 3rd for the better part of 1500 miles. I'm not sure where to start or what to do

GTyankee 06-28-2013 09:01 PM

It sounds like your transmission is stuck in LIMP MODE
i will let someone else tell you what you need to do

it may help to view these
http://www.google.com/#q=1999+dodge+...w=1067&bih=500


All times are GMT -4. The time now is 12:41 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger