DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   5.9L V8 Specific Topics (http://www.ramforumz.com/forumdisplay.php?f=173)
-   -   Rough idle.. Help! (http://www.ramforumz.com/showthread.php?t=146327)

DanTheMan 06-29-2013 04:46 PM

Rough idle.. Help!
 
I've had the problem ever since I bought the truck back in August, and its just been getting slightly worse and worse as time goes on.

Truck is a 1998 5.9L 4x4 with just under 170,000 miles

Okay, so the problem: about 2-3 minutes after I start it, the RPM's will drop down to around 500 or so, and it just doesn't want to run at all. when the RPM's drop, a loud hissing noise starts under the hood that is coming from the air intake.
If you are driving and the problem starts, it still doesn't want to rev at all. When you hit the gas, the RPM's will go up slightly, but then go straight back down. And if you keep your foot on the gas, it will start to pop and backfire. If you put your foot all the way down, it will downshift and the RPM's will jump up and the problem will go away for the rest of the trip.

If the truck sits for about a half hour or longer without running, the problem will occur every time you start it. It does it worse when it is hot outside or when the engine is already warm. Over the winter when it was really cold outside, the problem didn't really happen.

I tried a new idle air controller with no change. Any help would be great. Thanks in advance!

DanTheMan 07-04-2013 11:05 AM

Also I've noticed when driving with the A/C on and I go up a hill, the AC will cut out until I get to the top of the hill

Warlock III 07-04-2013 01:46 PM

Sounds like the IAC on the back of the throttle body. Around $40.

RogerRamJet 07-04-2013 02:23 PM

This video will confirm Warlock's diagnosis which sounds spot on.

http://www.youtube.com/watch?v=3JhRiAhKxwo

Warlock III 07-05-2013 01:10 PM

It may be a defective IAC that you replaced it with.

I'd take it back and try another. If not, then I'd lean towards an upstream 02 sensor.

DRX350 07-05-2013 01:13 PM

Check your fuel pressure.

DanTheMan 07-06-2013 03:28 PM

Fuel pressure checked out just fine. Just did another IAC today, and nothing changed

Warlock III 07-06-2013 05:40 PM

Unplug your upstream 02 sensors and reset the ECM. Then try it.

DRX350 07-07-2013 12:00 PM

No CEL?

if you have the opportunity, run a scope on the TPS, could be off, but not enough to trigger a CEL.

DanTheMan 07-10-2013 03:17 PM

Update: got the new O2 sensor(finally) shipped in from Advanced, threw it on and all is well. No more hints of the problem. Thank you everyone for your help!


All times are GMT -4. The time now is 06:20 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger