DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   Cummins Diesel Specific Topics (http://www.ramforumz.com/forumdisplay.php?f=187)
-   -   Bad Trans? Injectors? Need help (http://www.ramforumz.com/showthread.php?t=147541)

IndianaFALguy 07-14-2013 07:08 PM

Bad Trans? Injectors? Need help
 
So I have been in a 2 month nightmare with my truck. It's an 04 dodge ram 3500 nondually 4x4 w/a 5.9 HO cummins and auto tranny, 200,000 miles. 95gph fass lift pump, 4 or 5" straight pipe exhaust.

2 months ago 2nd gear went out so i took it to the tranny shop to get it rebuilt. Dropped $4,000 getting a transmission with tons of billeted parts. I was told it was a stage 3 billeted transmission. 2 weeks later, took it back to have rebuilt again because they didnt flush the trans cooler and all that gunk got blocked up in there and messed it up again. Then a week or 2 after that I took my truck to a diesel mechanic because of this pinging noise coming from injector #6 as well as horrible fuel economy. Used to get 20-22mpg highway, 16 in town empty, 12.5 towing in town. These were hand calculated consistently for years.

Diesel place checked it out and said #1 and #6 injectors were bad and numbers 2-5 weren't great.

So i paid for 6 new from the factory Bosch 100hp injectors. Cost $2,700. After I get the truck back they say, "oh they warned you about these right? If you use cruise control the truck will surge really bad." The answer is no, nobody told me. But I tested it and the surge in cruise makes it unusable. BS. Well, I took it highway driving today and when I hit 70 mph and hold it there, the truck is surging. Not using cruise control either. Also noticed a loss of power.

I also expected better fuel economy, they told me that with the 2 injectors bad I was losing 33% of my fuel to waste so that should increase. The injectors that were taken out were 150hp or more but wanted $300 to flow test them just to tell me what they were.

After these 2 jobs were done, the truck dropped below 10mpg towing in town, 16-17 highway empty, and 11.5 empty in town. Also, towing a 1500# trailer empty on the highway, I am redlining at 70mph. I've owned the truck 3 years and never redlined or even came close. Even towing 5000# going 80-85 mph.

Another odd thing, the overhead computer has changed since these jobs were done. I know not to trust it but am curious why it is suddenly reading differently. Did say that after a fillup I'd have 580 to 600 miles till empty, now it's reading 390 - 410 dte. The mpg highway is saying 16-17mpg, used to read 23-24. In town towing was saying 16, now it says 11.

I don't even know where to start. Is it transmission, injectors, both, or neither? If you need any more info let me know. Help would be GREATLY appreciacted.


All times are GMT -4. The time now is 02:24 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger