DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   5.7L V8 Specific Topics (http://www.ramforumz.com/forumdisplay.php?f=185)
-   -   Low oil pressure (http://www.ramforumz.com/showthread.php?t=147903)

89powerram 07-18-2013 04:58 PM

Low oil pressure
 
So I got on it today on the highway and right after that my check gauges light come on and my oil pressure was at L and it would come up to normal the. Go back down again I pulled over and turned the truck off started it back up again and it ain't come back on what is the deal

chefred112 07-18-2013 05:54 PM

did you check the oil level? if it's ok then it's possible the sender is going bad...

chefred112 07-18-2013 05:55 PM

if you get a check guage light for low oil pressure, first thing to check is if you have oil...

89powerram 07-18-2013 07:36 PM

The truck runs fine and the light only comes on whe. I hammer it

89powerram 07-18-2013 09:22 PM

Drove it home with the pedal on the floor damn this thing will run lol but it hasn't came back on and the oil pressure has stayed in the middle of the guage (knock on wood) idk what happend before

chefred112 07-19-2013 10:28 AM

you haven't told us if you have checked the oil level...this is kinda important.. almost sounds like at normal driving, oil level is enough to reach oil pump, when you hammer it, the centrifugal force is pushing the oil rearward. Oil pump is located at front of motor so there is a chance that oil level is low enough that none is getting to pump when you hit it..

89powerram 07-19-2013 11:42 AM

Quote:

Originally Posted by chefred112 (Post 1154215)
you haven't told us if you have checked the oil level...this is kinda important.. almost sounds like at normal driving, oil level is enough to reach oil pump, when you hammer it, the centrifugal force is pushing the oil rearward. Oil pump is located at front of motor so there is a chance that oil level is low enough that none is getting to pump when you hit it..

The oil level was fine slightly overfilled

Simple guy 07-19-2013 07:33 PM

Maybe junk in the pan? when you hit it the increased suction grabbed something in the pan temporary blocking oil pick up? or the pick up tube is bent and is sucking the bottom of the pan? I don't know I personally have never looked and the bottom end of the hemi with the pan off. Just my two cents.

89powerram 07-19-2013 11:30 PM

Well I noticed it only does it at like 90 degrees outside temp So I looked at the air temp sensor it was BAD dirty and my battery cables were really corroded so I wondering if that had anything to do with my other electrical problems


All times are GMT -4. The time now is 11:45 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger