DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   5.2L V8 Specific Topics (http://www.ramforumz.com/forumdisplay.php?f=172)
-   -   Engine just stops running (http://www.ramforumz.com/showthread.php?t=148663)

RAYJG 07-27-2013 04:52 PM

Engine just stops running
 
I have a 2001 Dodge Van with a 5.2 engine. The engine, when idling, just stops, but will restart every time. While driving, the engine stumbles with the "check engine light' momentarily flashing.

I have replaced the crank sensor, camshaft sensor in the distributor, ASD relay. coil, relay inside vehicle fuse panel which "clicks" when engine stumbles. The ASD relay also clicks twice during a stumble. The PCM has been replaced and rechecked. Throttle sensor also replaced.

It is like some sensor such as the temperature or oil that momentarily sends a false signal to the PCM computer which turns the ASD off and then on. I am at a complete loss as to what to do. Can anyone help, please?

amberatkins19 07-28-2013 02:41 AM

Hey I have an 02 mine did the same thing and it was idling low. Try changing your idle air control valve. After I changed mine I haven't had a problem with it since.


All times are GMT -4. The time now is 04:49 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger