DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   4.7L PowerTech V8 Specific Topics (http://www.ramforumz.com/forumdisplay.php?f=205)
-   -   03 Dodge Ram Engine Problems (http://www.ramforumz.com/showthread.php?t=149176)

DodgeRam1 08-01-2013 11:30 PM

03 Dodge Ram Engine Problems
 
Its been going off and on since I got the truck. But my engine revs up and down and when the RPMs get too low it shuts off. My engine light wasn't on for a while, while it was doing it but just recently came on, which I don't think the engine light has anything to do with it, but I would really like for it to stop so please help people. Thanks.

RogerRamJet 08-01-2013 11:35 PM

Um, the engine light has everything to do with it, Dood. Do you have a scan tool or code reader? I'm guessing probably not. Take it to a local parts store and have them read the code for you. They will probably give you some advice, but post what the code is and then we can go from there on what the issues may be. Until then, it's just a shot in the dark at this point. And shooting in the dark can get very expensive.

DodgeRam1 08-01-2013 11:39 PM

I'll take it, but everytime I have taken it to a parts store to get them to get the code they say it has nothing to do with why its revving up and down. But i'll take it down there and post the code on tomorrow.

RogerRamJet 08-02-2013 02:08 AM

Quote:

Originally Posted by DodgeRam1 (Post 1165641)
I'll take it, but everytime I have taken it to a parts store to get them to get the code they say it has nothing to do with why its revving up and down. But i'll take it down there and post the code on tomorrow.

Excellent! We'll help you best we can.

welshdog 08-03-2013 11:30 AM

Hi there, sounds like the same issue I had once. Turns out it was the TPS, (throttle position sensor) which was an easy cheap fix. Cost around $30 and 15 mins work. Good luck!

HemiLonestar 08-03-2013 05:35 PM

Quote:

Originally Posted by welshdog (Post 1166655)
Hi there, sounds like the same issue I had once. Turns out it was the TPS, (throttle position sensor) which was an easy cheap fix. Cost around $30 and 15 mins work. Good luck!

If I'm not mistaken the TPS is integrated into the electronic TB on the 5.7's. No replacing separately.

RogerRamJet 08-03-2013 05:56 PM

On the 4.7 it's a replaceable part. Two screws hold it on.

HemiLonestar 08-04-2013 01:25 AM

Quote:

Originally Posted by RogerRamJet (Post 1166920)
On the 4.7 it's a replaceable part. Two screws hold it on.

No, I'm an idiot and forgot I was in the 4.7 section...:doh:

DodgeRam1 08-04-2013 05:47 PM

Okay, so I got it checked and the code came up as P0441.

HemiLonestar 08-04-2013 07:48 PM

P0441 - Evap purge flow monitor


All times are GMT -4. The time now is 08:43 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger