DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   Towing (http://www.ramforumz.com/forumdisplay.php?f=202)
-   -   Can't select Heavy Electric on ITBC (http://www.ramforumz.com/showthread.php?t=151499)

kenwitter 08-27-2013 04:10 PM

Can't select Heavy Electric on ITBC
 
2 Attachment(s)
I recently traded my 2010 1500 for a 2013, and had the dealer install the OEM Trailer brake controller. I cannot get it to change the braking power from light electric to heavy electric. The dealer's techs kept it for almost two days and were unable to figure the problem out, even with chrysler Canada's help.

I access my vehicle settings through my radio, Model: 8.4N (not 8.4AN, which isn't available for Canadian market). I have all 4 brake options listed and can select heavy electric, however my EVIC is only giving me a light electric setting. At a gain of 10 and with full braking power (Meter goes to 100%) I'm not getting enough stopping power.

I had an OEM brake controller in the 2010 and the only way I got full power to my trailer brakes was with the heavy electric setting.

What I know:

ALL Trailer brakes are fine and working (4 trailers all tandem axle)

I am getting some stopping power, just not enough.

Uconnect software version: 13.15.4

No error codes recorded during trailer towing (dealer verified)

I can select all 4 break power settings on the radio, however i should only be able to select heavy or light electric on the 1500. I should not be able to select either of the Hydrolic options.

Evic displays everything else to do with the controller properly, just not the heavy electric setting.

What I think:

Something, somewhere needs to be updated.

If anyone knows of a solution or has a suggestion, I could really use some help. REALLY frustrating, but I dont want to take it out on my guys at the dealer. Normally they are excellent.

If you have the OEM brake controller and are able to select the Heavy Electric type, I would greatly appreciated your EVIC and/or Uconnect software version number.

The pics below illustrate my problem.

Thanks

Ken

h2oman 08-27-2013 05:32 PM

If I recall correctly Heavy Electric is for 3 Axle trailers. I can select Heavy but it does nothing since I have only 2 axles on my trailer.

kenwitter 08-27-2013 11:22 PM

You should always use heavy electric on Triaxles, but its not just for them. I should still be able to use it on tandems if i want to. I was always able to on the 2010 ITBC as well as the aftermarket controllers on my 2500s.

h2oman 08-28-2013 01:43 AM

Interesting. I can't make it work on my tandem and mine is factory. Wish I had more to offer you. Sorry.

kenwitter 08-28-2013 07:49 AM

No problem. Thanks.

RAMbunkshus 08-29-2013 11:16 AM

Same here
 
My 2013 Ram 2500 won't let me select "Heavy Electric" mode either. I asked the dealer's service mgr. about this, but he was clueless, said he'd have to "study up on it". His first response was that my trailer's brakes were probably weak, and that I shouldn't need the "Heavy" setting. I told him that the manual said "Heavy" was available, and that I should be able to select it, regardless of his opinion of my trailer's brakes!

kenwitter 08-29-2013 08:46 PM

1 Attachment(s)
Quote:

Originally Posted by RAMbunkshus (Post 1187575)
My 2013 Ram 2500 won't let me select "Heavy Electric" mode either. I asked the dealer's service mgr. about this, but he was clueless, said he'd have to "study up on it". His first response was that my trailer's brakes were probably weak, and that I shouldn't need the "Heavy" setting. I told him that the manual said "Heavy" was available, and that I should be able to select it, regardless of his opinion of my trailer's brakes!

That's the mentality I got at first. Until I packed him up and carried him to my workshop and showed him the brakes on ALL my trailers. Two of them were new, less than 1000km. Now they are 'researching it'. And even if your brakes are not tip top it should still be available.

The pic below shows an excerpt from my OM. For you in the 2500 you should be able to select all four braking options. For me in the 1500 I should be able to select only Light or Heavy Electric. The Hydrolic options are the only ones that should be unavailable to me.

I have four tandem axle trailers and two triaxles. I use this truck to deliver them to job sites empty. When empty my triaxles weigh 2000lbs and my tandems 1500lbs, way below the weight limit of the truck.

I was always able to select heavy electric on the ITBC on the 2010. So why is it an issue now? If all the literature states that we can use light and heavy electric on our 1500s why can't I select it? Light electric is not enough power for even the tandems.

Everything in writing state's that we should have this feature, and don't forget I had it on the 2010.

Does anybody anybody know how I can escalate this to Chrysler Canada. It's really becoming inconvenient now. I have to be taking my 2500s from job sites to deliver empty trailers.


All times are GMT -4. The time now is 09:25 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger