DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   Custom Dodge Ram Performance Mods - Engine - Dodge Cummins Diesel (http://www.ramforumz.com/forumdisplay.php?f=23)
-   -   2011 h&s mini max, egr, dpf, ccv delete mpg HELP! (http://www.ramforumz.com/showthread.php?t=151592)

Big Bad Ram 08-28-2013 12:31 PM

2011 h&s mini max, egr, dpf, ccv delete mpg HELP!
 
I bought a 2011 cummins 4x4 and it already had h&s mini max and dpf delete 4" straight pipe. It only got about 15 mpg. I installed s&b cold air intake, sinister egr delete and 5" straight pipe w/ flow through muffler. My mpg went DOWN 1mpg!?!:4-dontknow:
What could be the issue? I'm stumped! I have triple checked the muffler and it is positioned correctly.
Also I am getting a huge delay in throttle response that started before the recent mods.
Thanks for your input!!!

Big Bad Ram 08-29-2013 09:29 PM

Bump for ideas.
 
Bump for any ideas

NWRQC 09-02-2013 02:57 PM

Have you updated the tuner yet?
Are you hand calculating your fuel economy or going by the EVIC?
The EVIC is going to be inaccurate with the tuner on there.
The intake shouldn't affect your fuel economy either way unless you're pushing the skinny peddle more, to hear the new sounds. The EGR delete should actually increase your fuel economy. Did you disable/ remove the butterfly valve and actuator motor?

Big Bad Ram 09-03-2013 09:40 AM

I haven't done any updates to the tuner.
I'm mainly going by the comp for mpg but have hand calculated it a few times. It's a few numbers high.
I have not removed the butterfly valve but it should be disabled with the tuner.
The egr delete did seem to give me more power then I removed the 4" exhaust and installed the 5", that's when I lost some power and mpg.
I will look for updates for the tuner and let you know what I find.

NWRQC 09-05-2013 02:51 PM

Ryan re-did all the tuning for H&S not too long ago, they will be the latest updates on their site. It should be 6.8.47, make sure you update your firmware on the tuner then load the new tune. There are some new PIDS and setting changes which are all nice.
My computer is off anywhere from 1mpg to 8mpg depending on my driving. Since the tuner modifies some of the signals that the computer uses it's not going to be very accurate. I would only go off hand calculated for comparison purposes.
As long as the EGR is unplugged then it'll be fine. Going from 4" - 5" exhaust won't affect power or fuel economy, it might just be a coincidence.
I get a consistant 14- 4.8mpg highway or city driving.

Try cleaning your Map sensor, they tend to contribute to poor fuel economy when they are gunked up.

Big Bad Ram 09-06-2013 01:52 PM

Ok. So I updated my tuner (it was far behind) and took about a 400 mile trip. I hand calculated my fuel usage, I got 15.0. This is on a (Texas) highway through some hill country with towns and the occasional passing some slow drivers. I don't imagine interstate would be a whole lot better. Maybe slightly.
Before the trip I cleaned the turbo with a can of (non-flammable) brake clean. I figured that would help.
I do think that the 5" was just a coincidence as well.

Also one more issue I have that the update did not fix... I have a substantial lag in the throttle response when rolling and after I let my foot off (0% throttle) and back on again. Not racing around or anything. Just normal driving.
Thanks guys!

NWRQC 09-06-2013 09:02 PM

If you don't mind a little more smoke when you step on it, try changing to "low boost fueling" on. It will add a little bit more fuel down low to help spool the turbo and increase throttle response down low.

Big Bad Ram 09-17-2013 03:08 PM

I don't believe it is turbo lag. The engine doesn't even seem to try to apply fuel or idle up in that short time period. I could be wrong but it just seems to me that it is something else. I don't remember feeling that lag a few months ago when I first started driving it. It seems to happen when i shift on the fly. Sometimes it gets real bad and last almost a full second. Hit the throttle, prepare for launch and no go. Then she GOES! Lol

NWRQC 09-17-2013 03:40 PM

Try switching to "low boost fueling" on.
The ability to adjust throttle sensitivity (old tunes) was removed because I believe that it caused issues with the transmission tuning.
It was talked much about in another thread that he created on another forum when he was sending out test tunes while creating the new tunes.
He added that option (low boost fueling) for people who wanted some of that peddle feel back and don't mind the added smoke.
The tunes drive a little different because one of his main goals was to reduce the amount of smoke with the tuning. One of the ways to do that is to reduce the amount of fueling which changes the throttle response.
Also set your max timing to 32* that will help the top end.

Big Bad Ram 09-17-2013 04:50 PM

I will try those settings and let you know the outcome.
This might be slightly off subject but would you recommend the h&s trans tuning? Would it possibly help with in town mpg? And keep from lugging the engine down at lower speeds?


All times are GMT -4. The time now is 04:44 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger