DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   Electrical (http://www.ramforumz.com/forumdisplay.php?f=199)
-   -   Overhead dome light switch not working (http://www.ramforumz.com/showthread.php?t=154667)

neuman22 10-02-2013 04:55 PM

Overhead dome light switch not working
 
Has anyone had problems with the overhead dome light not working? When I click the light to turn it on it won't work, but when I turn on all the lights with the dimmer switch they'll come on and will also cut off if I click the light while I have all the interior lights turned on using the dimmer switch. Freaking weird, a fuse, or bad relay maybe?

RogerRamJet 10-03-2013 02:10 AM

What kind of lights do you have in it? LED's? You may have an issue with there not being enough load for it to come on. In which case you would have to solder a resistor on to the bulb.

neuman22 10-03-2013 07:57 PM

Nope, no LEDs, it's all factory. I haven't changed anything out.

RogerRamJet 10-03-2013 11:29 PM

Ok, maybe a bad bulb? I was having an issue like yours, except it was with my map lights. Different generation Ram, so I'm guessing a different issue. I fixed mine with a resistor. Now I'm stumped. I reckon it's time to break out the volt meter and start testing and troubleshooting. Wish I could've been more help.

neuman22 10-10-2013 01:16 PM

I'd do that, but like I mentioned in my first post the light works when I turn on all the interior lights via the dimmer switch next to the headlight switch. They just won't work individually when I try to turn them on. I'm stumped

RogerRamJet 10-11-2013 12:07 AM

Mine did the same. Would work when the door was opened or if I turned them on with the switch, just not individually. With the resistors, they work great now, both with the door/switch and individually.

gcscott 10-11-2013 09:59 AM

Quote:

Originally Posted by neuman22 (Post 1213010)
Has anyone had problems with the overhead dome light not working? When I click the light to turn it on it won't work, but when I turn on all the lights with the dimmer switch they'll come on and will also cut off if I click the light while I have all the interior lights turned on using the dimmer switch. Freaking weird, a fuse, or bad relay maybe?

Sounds like a bad switch on the light.

Grubrunner 10-11-2013 10:46 AM

Yes, if they work one method and not the other than you can rule out the bulb.

The switch is a good start.

neuman22 10-14-2013 11:59 AM

So another thing I noticed when my wife pulled down the visor to use the mirror yesterday is the vanity lights are not working either. Anyone know if these are all on the same switch, fuse, or relay?

RogerRamJet 10-14-2013 01:15 PM

They probably are on the same fuse (interior lighting). Since you do have light, I'm guessing it's not the fuse, more likely a burnt out bulb or faulty switch.


All times are GMT -4. The time now is 05:15 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger