DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   Custom Dodge Ram Performance Mods - Engine - 5.7 HEMI V8 (http://www.ramforumz.com/forumdisplay.php?f=83)
-   -   WOT power lose. (http://www.ramforumz.com/showthread.php?t=155174)

BiggBoy 10-08-2013 09:45 AM

WOT power lose.
 
I have a slightly modded truck

ARH headers, S&B intake, 87mm TB, and full custom exhaust.

Right now I'm running a hemifever custom tune. I love the tune, pulls much harder then running a canned tuned. But I have a problem with both tunes.

When I'm a WOT It seems to bog down a little in the 2500-4000rpm range. If I let off it a little while its bogging down. It will take off like a bat out of hell.

Other thing I noticed is that right after I get my oil changed the bogging stops for about 500 miles (my 0-60 times on my trinity confirm its true.)

I took it to one shop, and they are convinced they could fix my problem with there $800 dyne tune...

I might throw a AF gauge in to see if it pulls rich or lean in when this is happening.

Any ideas what it could be?

battlerattle 10-08-2013 01:47 PM

Not sure how it ties to your oil change, but it sounds like your running out of fuel/pressure. I know alot of people have been switching to the aeromotive pumps for boosted applications, you might be on that threshold.......then again I could be completley wrong.

chefred112 10-08-2013 07:15 PM

do you have a wb that you can see af ratio when in open loop (wot)?

moparornocar72 10-08-2013 08:35 PM

I would send some live feed from your tuner to hemifever and make sure everything is where it needs to be as far as tune and numbers and then go from there.

BiggBoy 10-08-2013 09:17 PM

Quote:

Originally Posted by chefred112 (Post 1217296)
do you have a wb that you can see af ratio when in open loop (wot)?

I do not yet.

Quote:

Originally Posted by moparornocar72 (Post 1217390)
I would send some live feed from your tuner to hemifever and make sure everything is where it needs to be as far as tune and numbers and then go from there.

I have, he says everything looks normal from what he can see.

BiggBoy 10-08-2013 09:19 PM

Quote:

Originally Posted by battlerattle (Post 1217076)
Not sure how it ties to your oil change, but it sounds like your running out of fuel/pressure. I know alot of people have been switching to the aeromotive pumps for boosted applications, you might be on that threshold.......then again I could be completley wrong.


The oil change part stubbles me also. I could dump a little more fuel into the motor via my trinity I guess. I can't see how a mostly stock NA motor can pull that much.

moparornocar72 10-08-2013 09:43 PM

Hmm......I would go with what chefred said and try to check what your a/f ratio is...

chefred112 10-09-2013 12:06 AM

interesting..I was hoppin onto the freeway today and decided just to go 3/4 throttle instead of wot...and if I didn't know any better, it almost felt stronger... but when you think about it, you need to give a wot datalog that includes a/f logging to your tuner (unless your tuning on a dyno)...my tuner is always harpin on me to get him some form of a/f logging in open loop (wot)

jbonner 10-09-2013 11:27 AM

mine bone stock and feels stronger at 3/4 throttle than foot down evertime... i dont understand it either

chefred112 10-10-2013 07:39 PM

yup...did a wot stab while starin at wideband...it dropped all the way down to 10.8's to low 11's, that's definitely pig rich for it...


All times are GMT -4. The time now is 12:27 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger