DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   Custom Dodge Ram Interior and Exterior Lighting (http://www.ramforumz.com/forumdisplay.php?f=78)
-   -   Brighter Backup Bulbs in an LED equiped Ram (http://www.ramforumz.com/showthread.php?t=155848)

mineralram 10-16-2013 11:57 AM

Brighter Backup Bulbs in an LED equiped Ram
 
Anybody running Brighter Backup bulbs in a 2013 Ram that is factory equipped with the LED package. I noticed that the Backup bulbs are not LED's and would like to install brighter ones that would increase night vision with backup camera.

gcscott 10-16-2013 12:21 PM

I ordered a set of HID backup lights. I am still waiting for them to show up, they are on the slow boat from China. Should be here today.

I will post if I can get them to work or not. Not sure if the wiring has enough power to fire the ballast or if they will hyper flash. Rolling the dice again on another Mod.

Item is here: http://www.aliexpress.com/item/HID-R...761205345.html

Greg

atmotocrosser 10-16-2013 12:50 PM

I'm tagging along since I'm interested in this too. :smiley_thumbs_up:

Sohighlyunlikely 10-16-2013 12:53 PM

Quote:

Originally Posted by gcscott (Post 1222300)
I ordered a set of HID backup lights. I am still waiting for them to show up, they are on the slow boat from China. Should be here today.

I will post if I can get them to work or not. Not sure if the wiring has enough power to fire the ballast or if they will hyper flash. Rolling the dice again on another Mod.

Item is here: http://www.aliexpress.com/item/HID-R...761205345.html

Greg

I had ordered something from them earlier this year. After waiting for a month. It hadn't even shipped. I hounded them and eventualy got a full refund.

Doc

Monster5601 10-16-2013 01:18 PM

Quote:

Originally Posted by gcscott (Post 1222300)
I ordered a set of HID backup lights.

My concern would be the start-up time it takes for a HID to go to full output.

Quote:

Originally Posted by atmotocrosser (Post 1222327)
I'm tagging along since I'm interested in this too. :smiley_thumbs_up:

Me three.

Silvercreek 10-17-2013 05:58 AM

The stock backup lights on my 2013 Laramie Longhorn are a lot brighter than the ones on my 2010 F150 were.

Asur 10-17-2013 09:33 AM

I have a set of HID backup units, there great, at start up they are the same lumans as the OE bulb, but after about 3 sec's they are very strong. You can also get backup LED bulbs from many places but I tried a few, because of the way the reflector and the position of the bulb is in the Ram you need to get bulbs that have Side led's for a good light output.

http://www.carid.com/images/lumen/ca...cw-lighted.jpg

gcscott 10-17-2013 10:12 AM

Quote:

Originally Posted by gcscott (Post 1222300)
I ordered a set of HID backup lights. I am still waiting for them to show up, they are on the slow boat from China. Should be here today.

I will post if I can get them to work or not. Not sure if the wiring has enough power to fire the ballast or if they will hyper flash. Rolling the dice again on another Mod.

Item is here: http://www.aliexpress.com/item/HID-R...761205345.html

Greg

I got the HID lights.

I tested the lights with my 12v power supply and they fired up. Went out to the truck and Installed one side to see what I get and the HID light flashed 3 times, stopped, flashed 3 more times, than got nothing.

I put in the OEM bulb and got nothing, no power in the circuit. Turned off the engine and than restarted. OEM bulb relight. Not enough power to fire the HID ballast. Dam electrical system!

My next attempt will be trying to use power from the 7 pin trailer plug wiring where I have my light bar wired into the reverse light.

This is not going to be plug & play if it works. Will update.

Greg

Silvercreek 10-17-2013 10:25 AM

Quote:

Originally Posted by gcscott (Post 1223089)
I got the HID lights.

I tested the lights with my 12v power supply and they fired up. Went out to the truck and Installed one side to see what I get and the HID light flashed 3 times, stopped, flashed 3 more times, than got nothing.

I put in the OEM bulb and got nothing, no power in the circuit. Turned off the engine and than restarted. OEM bulb relight. Not enough power to fire the HID ballast. Dam electrical system!

My next attempt will be trying to use power from the 7 pin trailer plug wiring where I have my light bar wired into the reverse light.

This is not going to be plug & play if it works. Will update.

Greg

That's one of the reason I've learned not to modify any of the electrical, suspension or mechanical systems on these late models. The benefits may not out weigh the potential issues.

GilAlex 10-17-2013 12:07 PM

I used 9 SMD 921 bulbs in my 2013 RAM Express.
They are really bright and did not cost a lot of money.
Try iJDMToy.com or BrightLEDLights.com
There is probably enough room for 13 SMD 921 bulbs.


All times are GMT -4. The time now is 03:01 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger