DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   Electrical (http://www.ramforumz.com/forumdisplay.php?f=188)
-   -   2006 Ram - Radio won't turn on after cold start. (http://www.ramforumz.com/showthread.php?t=156802)

mlc63 10-26-2013 09:38 PM

2006 Ram - Radio won't turn on after cold start.
 
I have a 2006 Dodge ram 2500 work truck which recently developed a new electrical problem. The stock radio with clock won't turn on after I start the truck for the first time of the day. Clock is not lit up either. I drive the truck to work - about 15 minutes and everything is dead.

Shut the engine off and restart it and both the radio and clock are back on. The clock has the right time too. If I do errands throughout the day the radio works just fine.

I'm assuming that the 'start' circuit computer must shut off things like the radio so that all 12v goes to the starter on cold starts.

I'm puzzled and don't really know where to start!

Any help would be greatly appreciated.

Steve

mrseav77 11-27-2013 03:58 PM

Same problem.
 
Just did a search and found this thread. This was the second time I've had this happen and it's always on a cold day. Works fine after warming up. Someone please help!

SPGroth 11-18-2014 02:35 PM

Have a 2006 Dakota. Had similar issues with the radio. It would not turn on at times. The clock would always keep time and I never lost my save radio stations. After a week or so, I began to get hints that my battery was getting weak. Had the battery checked and it was bad. Changed out the battery and now the radio functions like it is supposed to.

jackwill12 11-19-2014 04:55 PM

I have a 2006 Laramie 3500 and my radio with the navigation and ves with 6 disk changer, just started acting up. the display will work when I start the truck, but after a few minutes the screen goes blank and all I can control is the volume. nothing else will work. Some times when I pull the key and reinsert it will all come back on but only for a few minutes and all goes off again. any suggestion on what I might be able to do?


All times are GMT -4. The time now is 04:37 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger