DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   2010 Dodge Ram Forum (http://www.ramforumz.com/forumdisplay.php?f=79)
-   -   FOB Remote Starter/Malfunction Indicator Light (http://www.ramforumz.com/showthread.php?t=158963)

saskplumber 11-20-2013 07:44 PM

FOB Remote Starter/Malfunction Indicator Light
 
Hey Guys.So here's my problem.I live in Southern Saskatchewan and if any of you know the part of the country,you know it can get dam cold here in the winter.I love my truck but I HATE the remote starter.When it dips down the Malfunction light always come on and stays on for periods of time.When it's on you can't use the remote starter and it drives me crazy.Should I have a sensor replaced?Can I get the MIL disabled somehow?Would the remote starter work with it disabled?

I was planning on putting in a aftermarket remote starter next week,but if this nonsense keeps happening,probably going to scrap that idea.

Thanks

Asur 11-21-2013 10:03 AM

For about 80$ you can get yourself an Xpess kit DB-ALL, it will use your current remote, will install in like 15 min (plug and play), not cutting into any wiring uses a T-connector cable under your dash to your ignition key module, might be a way to go if you have to pay the dealer to look at your current remote start setup. Just a thought

dbuzz77 11-21-2013 11:57 AM

do you mean that light with the lightning bolt? if it is that i think that is a communication error and should be looked at.

saskplumber 01-05-2014 04:58 PM

I think I have a bad Oxygen sensor.The MIL will come on and the eco will not work.This has been ongoing for too long.Gonna contact the shop in the morning and ask they replace it.The truck has always ran great but this is a pain in my :SHOCKED:.So if the MIL goes away does the truck store the error code from the problem?

Thanks
J

saskplumber 01-10-2014 08:23 AM

Well that was a big waste of time.Took the truck in and they told me the MIL/error was due to engine misfire and that there were codes for these misfires but they had already applied the code updates to my vehicle sometime ago.They said my O2 sensor was fine.They quoted me approx 780$ to replace all the O2 sensors.F-that!!!!Guess I'll just live with the random MIL.
Told the wife that she's lucky the truck is in her name,I probably would of went to the other dealer on the way home and traded her in on a custom/sierra.:FIREdevil:Thats how much I hate that dam MIL.

Thanks
J

GearHd6 01-10-2014 10:56 AM

MIL's and CEL's are the wave of the future I think. I wouldn't expect any particular manufacturer to be any better in that regard. Some people get vehicles that treat them great and someone else will have the same vehicle that gives them nothing but headaches. It's all a gamble. If you don't want a CEL/MIL, buy a non computer non emissions truck. A nice 78 Power Wagon would be nice. :)

Hmmm..., now that I think of it. A 78 Power Wagon with a 5.9 Cummins manual pump engine, 6 speed manual with A/C?

Bluedragon436 01-10-2014 04:15 PM

Quote:

Originally Posted by GearHd6 (Post 1291588)
A nice 78 Power Wagon would be nice. :)

Hmmm..., now that I think of it. A 78 Power Wagon with a 5.9 Cummins manual pump engine, 6 speed manual with A/C?

Agreed and AGREED~!!! Only issue I keep having pop up even though I've checked the tires multiple times is a random low tire press message.. other then that nothing yet, as far as MIL thank goodness... But I would love to find an old Power Wagon or even a decent shape M715 and an old school 5.9 Cummins back by a nice 6spd and maybe even the heavy duty axles from a Ram 2500 just to freshen up the drivetrain completely!!


All times are GMT -4. The time now is 12:26 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger