DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   Dodge Ram 4x4 - Offroad Discussion (http://www.ramforumz.com/forumdisplay.php?f=213)
-   -   Hay Wired (http://www.ramforumz.com/showthread.php?t=165327)

c taylor 01-31-2014 07:49 AM

Hay Wired
 
Got this 01 2500 5.9 Mag. 4x4, having a heck of a time with the O/D off light. Start the engine, light comes on and stays on till you press button on shifter. Fan switch has to be on 2nd notch so compressor doesn't cycle. If you switch AC on while running O/D light comes on , it also downshifts if you are at highway speed, if you press brake pedal at highway speed , light comes on and downshifts. Have cleaned all grounds, replaced brake switch, replaced tps... what to do ?

mb power wagon 01-31-2014 03:08 PM

have you looked at your fuse block to see if something is wrong there? it sounds like several circuits are being crossed. or it could be broken wires in the dash harness.

c taylor 02-01-2014 03:51 PM

could be under dash, the cover is cracked and the truck was crashed on pass. side at onetime, before me owning it

Lazarus Truck 02-06-2014 08:46 PM

You seem to be looking in the right place. With DC, if it don't work, check power. If it works weird, check grounds. Double-check engine to chassis ground?

PostalTwo 02-18-2014 12:35 AM

i sound definitely like a ground issue id put money on it if u have the ac off and heat set to vent does it do it?


All times are GMT -4. The time now is 08:58 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger