DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   5.2L V8 Specific Topics (http://www.ramforumz.com/forumdisplay.php?f=172)
-   -   Cold Engine knock 95 ram 5.2 liter (http://www.ramforumz.com/showthread.php?t=38022)

kccoln 02-13-2009 08:04 PM

Cold Engine knock 95 ram 5.2 liter
 
I have a 1995 Dodge ram 1500 with the 5.2 liter.It has 145000 miles.It runs excellent,carries good oil pressure.I changed oil in it and developed a cold engine knock at idle mainly and the knock completely vanishes after truck gets to normal operating temp.The knock sounds to me like it is coming from the intake area.The engine purrs like a kitten.Powerful.It runs as good cold as warm but has the knock when cold.It did not do this until I changed oil.I used pennz 10w-30 high mileage oil.It is a knock and not a tick.It doesnt sound like its going to throw a rod loud,but very noticable.The previous owner ran havoline 10w-30.I cant figure it out.Has anyone had the same problem?Should I switch back to havoline?Can anyone tell me what it is?Im pretty sure its not piston slap,lifter maybe but I thought they were more of a tick and not a knock.Could it be something with the intake or injectors?Please help.Im going crazy trying to figure it out.

Thanks

black beauty 02-14-2009 11:53 PM

you can try switching back to havoline it can't hurt any, i'm a mobil 1 guy and i have never had a problem with it yet with my 2000 5.9L and it just cranked over 120,000.

what grade of gas do you use?
you can try going up a grade that might help. or you can use fuel injector cleaner or octane booster i've heard that works sometimes.

but if i were you i would try and go back to the old havoline first, i have heard some really wierd stories about motor oil and engines so try that first and get back to me when you do i would like to know what happens.

kccoln 02-15-2009 12:15 AM

Hi

I just bought the havoline today and Im going to change it tomorrow.I also bought a purolator filter this time.I hear they are the best for retaining the oil in the engine without dumping it back into the pan.I have used seafoam in the tank and oil,and no results yet.As far as gas,I have always used the cheap stuff and never had any problems.I could try some premium,I guess.Im going to try the havoline,if that doesnt work Im going to try this stuff called Zmax.If that doesnt work,I may pull the pan and check the pump and screen for blockage.perhaps the pump is weak,not getting proper lubrication to the top of engine at startup.If I pull the pan,Im hoping I do not see something i do not want to,if you know what I mean.Ill let you know if the havoline is a fix.Thanks for your input.I appreciate it.

kccoln 02-17-2009 06:03 PM

Cold engine knock
 
Switched back to Havoline.There wasnt any change.There werent any foreign materials in the oil.It looked great no grit no grime, and no metal.One thing I did notice was during warm up the engine surged a couple of times and each time the knock went away for a split second.This happened once before I switched oils and twice in a row the next day after I switched.

Any ideas with the new symptoms?Im about ready to take the plunge and take it to a mechanic.Its out of my league.

Anybody know anything about this? Thanks


All times are GMT -4. The time now is 10:53 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger