DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   Body & Interior (http://www.ramforumz.com/forumdisplay.php?f=200)
-   -   Multiple Displacement System (MDS) (http://www.ramforumz.com/showthread.php?t=38581)

sincebeen 04-03-2009 08:43 PM

Multiple Displacement System (MDS)
 
I have yet to see an alert on my EVIC when the Multiple Displacement System (MDS) is in use. My uncle says his has some sort of alert (maybe next to the speed control symbol) that comes on when the MDS is in use.

Anyone else?

Burkdadhemi 04-03-2009 08:59 PM

Mine don't say shit, You just feel it.

08quadram 04-04-2009 12:26 PM

I don't believe there is any indication anywhere except surging

sincebeen 04-06-2009 10:10 AM

That's correct if you have a 08 or earlier model - I think. The new EVIC is supposed to - I think - display something when MDS is in use. I know someone else is having this issue with their 09... I think I'll just have to stop by the dealer.

erm 04-06-2009 10:44 AM

I've never seen it on the trucks. I have seen it on MDS 5.7L LX cars in the EVIC.

cpelton 04-07-2009 03:32 AM

havent seen it on my new 09 yet

Joe 04-08-2009 04:19 PM

I haven't seen this on my 08 1500 Big Horn. I feel it though when I am in town as the truck seems to be sluggish when crusing at 25mph almost as if on 4 cylinders and then if I push on the accelerator a bit more it catches up like all 8 cylinders just kicked in. On the highway I can't really feel it but I can see the gas miles change as it is engauged.

Megacab07 04-08-2009 04:26 PM

no indicator light on my 07, just the sound and tach jumping up and down.

musclecar69 04-10-2013 02:53 AM

MDS ECO light
 
On my 12 model you go into a settings menu all the way to the bottom and you can choose whether it displays the ECO symbol or not. Might just be turned off.

Jon3sgte 04-18-2013 02:32 PM

Quote:

Originally Posted by Joe (Post 57253)
I haven't seen this on my 08 1500 Big Horn. I feel it though when I am in town as the truck seems to be sluggish when crusing at 25mph almost as if on 4 cylinders and then if I push on the accelerator a bit more it catches up like all 8 cylinders just kicked in. On the highway I can't really feel it but I can see the gas miles change as it is engauged.

If I'm not mistaken, the MDS wont kick in until 40+ mph. My 07 300C didnt have a light that showed when the MDS came on.


All times are GMT -4. The time now is 04:23 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger