DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   5.2L V8 Specific Topics (http://www.ramforumz.com/forumdisplay.php?f=172)
-   -   power steering leak (http://www.ramforumz.com/showthread.php?t=39392)

94beast 06-02-2009 11:57 PM

power steering leak
 
i have a 94 dodge ram 1500, i came out of work one night and i had a huge puddle on the ground. it leaked when i first got the truck and i put the "stop leak" stuff in but no good. i put trans fluid in it because trans fluid is thicker than power steering fluid ( did this like last winter) it stopped leakin. but now its leaking again. it leaks right where the pitman arm shaft it. i jus need the seal that goes there. anyone knw how hard it is to get that seal out? i got the nut off the arm, i got to get a puller to get the arm off. any help?

thanks jay

Sparky 06-03-2009 11:51 PM

I have never replace seals like that personally. I think they make rebuild kits that have everything you need. They make those kits for calipers also, but I always buy new sealed units.

MountainMover 11-01-2015 12:04 AM

Quote:

Originally Posted by 94beast (Post 62081)
i have a 94 dodge ram 1500, i came out of work one night and i had a huge puddle on the ground. it leaked when i first got the truck and i put the "stop leak" stuff in but no good. i put trans fluid in it because trans fluid is thicker than power steering fluid ( did this like last winter) it stopped leakin. but now its leaking again. it leaks right where the pitman arm shaft it. i jus need the seal that goes there. anyone knw how hard it is to get that seal out? i got the nut off the arm, i got to get a puller to get the arm off. any help?

thanks jay

Damn...not since 2009??
I just searched the forum for the same issue on my 2012 2500 slt, and this was the only post about it. My leak is very slight, but a leak no less.
I was quoted around $600 to replace the entire power steering pump...for a leaky seal....?
I guess this is an extremely rare issue, but damn, the rig only has 60k miles on it.
If anybody has any bit to add, I would appreciate some feed back


All times are GMT -4. The time now is 07:01 AM.

Powered by vBulletin® Version 3.8.10 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger