DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   Heating & Cooling (http://www.ramforumz.com/forumdisplay.php?f=177)
-   -   Air Condition on '96 1500 (http://www.ramforumz.com/showthread.php?t=39920)

anticommander 06-24-2009 01:32 PM

Air Condition on '96 1500
 
I noticed that my AC wasnt actually blowing cold air so i figured i would try to recharge the system. I connected the hose and read the pressure but it seemed to be just fine. I did notice that the compressor would turn on and the pressure would drop to about 20 PSI then the compressor would turn back on and the pressure would rise to abou 50 PSI.

Is the compressor supposed to be doing this?

Am i supposed to have a consistent reading instead of fluctuating between 20 and 50 PSI?

What other things could be causing this?

jjtroutbum 06-24-2009 10:51 PM

Me to tagging along for more info.

chithead 06-25-2009 09:41 AM

Sounds like the system may be a bit low. According to a suggestion from an automotive A/C sight, the PSI of the system should be about equal to the outside air temperature when running. Can you see any fluid or foaming in the sight glass? May be some moisture in the system causing the pressure change.

anticommander 06-26-2009 12:38 AM

well i went back out and just opened the can all of the way and i saw the compressor engage consistently and the recharge can started to get cold in my hand, and now i have cold A/C. I guess it was just patience

chithead 06-26-2009 09:41 AM

Well that is good news! Gotta have the cold air this time of year.


All times are GMT -4. The time now is 12:00 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger