DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   Dodge Ram General Discussion (http://www.ramforumz.com/forumdisplay.php?f=10)
-   -   Cold Air intake question (http://www.ramforumz.com/showthread.php?t=40785)

06DodgeRam 08-06-2009 06:49 PM

Cold Air intake question
 
i have a k&n cold air intake, i got a hemi does anyone else have the air intake on and does it make a weird tickin noise at lower RPM's..i checked and checked can't be a air leak everything's tight and sealed..:4-dontknow:

ramit04 08-06-2009 07:11 PM

vacume line?

johnnyk416 08-06-2009 09:12 PM

Hemi tick ......... its the EGR valve gets intensified by cold air intakes, nothing to worry about:smiley_thumbs_up:

Toms Blue Ram 1500 08-06-2009 09:14 PM

Never heard of it . Good to know .

johnnyk416 08-06-2009 09:19 PM

Quote:

Originally Posted by Toms Blue Ram 1500 (Post 72665)
Never heard of it . Good to know .

LOL ..... thats because you don't have a Hemi. Search other forums Like HTC you will find many posts on it. Almost sounds like valves out of adjustment or an exhaust leak..... very noticeable at a drive up teller window(kinda embarrassing to)........LOL

Excoastie 08-07-2009 07:44 AM

I had a K&N Typhoon on my wife's Magnum. I had what often sounded like a "pinging" sound coming from under the hood. It was mostly during acceleration, but it also happened sometimes at idle.

Came to the conclusion that it was the warmer air from the engine bay, mixing with the cooler air that it was sucking in, (it seems that the seals around the heat shield were not very good, if they worked at all).

I had a friend of mine help me to better close up the open spaces around the heat shield. We used a bit of sheet metal, some quick welds, and a bit of weather stripping. The decreased the pinging, but didn't completely cure it.

Not sure if you've got the same problem, but that's what happened with me. I've had no trouble out of the AEM brute force I've got on my Ram...

good luck

Exco

Toms Blue Ram 1500 08-07-2009 03:29 PM

Quote:

Originally Posted by johnnyk416 (Post 72671)
LOL ..... thats because you don't have a Hemi. Search other forums Like HTC you will find many posts on it. Almost sounds like valves out of adjustment or an exhaust leak..... very noticeable at a drive up teller window(kinda embarrassing to)........LOL

No but being a mechanic and working on them :doh:

06DodgeRam 08-07-2009 10:24 PM

oookay, so could be the EGR or could be the warm cool air mixing, and yes all vaccum lines are sealed...i tried everything from grabbin the shield box and shakin the heck out of it to pullin the heat shield off the inside of the hood cuz i thought maybe it suckin air it was vibrating it cuz there not put up there very tightly....but u guys think this is nuttin to worry about, cuz i know that somethings with air intakes not on right can lead to serious problems...thanks for all the input also

06DodgeRam 08-07-2009 10:26 PM

Quote:

Originally Posted by johnnyk416 (Post 72671)
LOL ..... thats because you don't have a Hemi. Search other forums Like HTC you will find many posts on it. Almost sounds like valves out of adjustment or an exhaust leak..... very noticeable at a drive up teller window(kinda embarrassing to)........LOL

AND YES IT'S THE ANNOYING SOUND OF A EXHAUST LEAK....but mine only makes the noise on easy acceleration at low RPM, when im into it, no noise

TerryXn9 08-07-2009 11:27 PM

I got the 4.7 magnum with no cai. It makes a ticking noise at idle. I took it to the dealership and they told me it was the hydralic lifters. They also said its louder in the hemi. Not sure if thats what it is but it took my mind off of my problem.


All times are GMT -4. The time now is 04:24 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger