DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   Custom Dodge Ram Performance Mods - Engine - 5.7 HEMI V8 (http://www.ramforumz.com/forumdisplay.php?f=83)
-   -   4 Wheel Drive Problem (http://www.ramforumz.com/showthread.php?t=41295)

mrbrace 08-30-2009 11:01 AM

4 Wheel Drive Problem
 
So yesterday I was hauling some sod over to my brother in laws house (leftovers from soding my yard). I had to go through some weeks in the field behind his house so it was easier to carry them onto his yard. I put the truck into four wheel drive and off i went.

I didn't go fast at all and was just moving through the weeds without any problems. We unload the sod and drive the truck back through the weeds. After getting out of the field I put the truck back into 2H and for some reason it felt like the brakes were on (like I was trying to powerbrake). All four of the tires were squealing and the truck was hesitating. I parked it, put the bottom 4WD lever into neutral to see if it would stop, couldnt get it out of neutral once it was in there. I tried and tried pulling it back into 2H and it wouldnt go. I finally put the truck in drive and eased it into 2H only to hear a loud clunck (yes I had my foot on the brake).

The truck was still squealing the tires as if I was trying to power brake and it was hesitating so bad. I finally stomped on the gas and it broke free into 2H. Has anyone has this issue? Sensor? Linkage?

I am taking it in on Tuesday to the mechanic, just wanted to see if anyone had this issue.

TIA
Matt


All times are GMT -4. The time now is 02:28 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger