DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   Dodge Ram Videos (http://www.ramforumz.com/forumdisplay.php?f=50)
-   -   Poor quality 30ish-65ish video (http://www.ramforumz.com/showthread.php?t=41383)

98sst 09-01-2009 11:20 PM

Poor quality 30ish-65ish video
 
Eh not too bad for a 5.9 that has 116,5xx miles on it. Mods include but aren't limited to headers, K&N CAI, Taylor ignition cables, Air raid throttle body spacer, Magnaflow exhaust, jet power control module. Yes, this was with a Cell phone, sorry! I'll mount a camera soon, I promise this truck is quick! By the way, the orange light you see in the bottom right is the O/D OFF light

http://i97.photobucket.com/albums/l2...0901091905.jpg

Red Ram 09-01-2009 11:24 PM

http://www.ramforumz.com/showthread.php?t=41338
"I don't hit the gas too hard too often"

98sst 09-01-2009 11:26 PM

I see, but if you read on :)

"It seems another ram owner (99) has the EXACT same problem, as posted in another thread. I'm going down to Walt's today to get it flushed and a new filter... Hope it works."

And yes, it did work. Lol. Turned out the filter and fluid needed to be swapped. This was on the way home!

chithead 09-01-2009 11:28 PM

Awesome! Glad she is back to normal.

98sst 09-01-2009 11:31 PM

Quote:

Originally Posted by chithead (Post 77963)
Awesome! Glad she is back to normal.

Yup! Thanks man! Me too, Theres a test-and-tune coming up this month I plan on attending with this. Curious what it'll achieve. i'd guess mid-high 15s. Not too sure. And As I said before, Sorry for the poor quality!

Red Ram 09-01-2009 11:41 PM

I read these same things in several forums that I visit and it always make me laugh..... My "whatever it is" burns lots of oil, over heats, make grinding noise's etc... then you look at their sig and it has ..... NOS,overdrive pulley, turbo, bigger waste gate, 57" tires etc....
Glad the filter and fluid did the trick... "Keep on Trucking"

98sst 09-01-2009 11:46 PM

Quote:

Originally Posted by Red Ram (Post 77965)
I read these same things in several forums that I visit and it always make me laugh..... My "whatever it is" burns lots of oil, over heats, make grinding noise's etc... then you look at their sig and it has ..... NOS,overdrive pulley, turbo, bigger waste gate, 57" tires etc....
Glad the filter and fluid did the trick... "Keep on Trucking"

Hahaha! Yeah, I'm just thankful everything is in as good of shape as it is. No major probs, let's keep it that way. Glad it was just the filter and fluid aswell. Hope to catch you around the forums!

Toms Blue Ram 1500 09-02-2009 12:23 AM

Cool , now it's time to go abuse the hell out of it !!!!!!!!!!!!!!!!!!!!!!!!!!

98sst 09-02-2009 12:25 AM

Quote:

Originally Posted by Toms Blue Ram 1500 (Post 77977)
Cool , now it's time to go abuse the hell out of it !!!!!!!!!!!!!!!!!!!!!!!!!!

Haha! Only at some times, I did state in the other thread I had a tranny problem, which was fixed today with a fluid/filter swap. Filling up with 230 miles on the clock and 55 bucks is no fun, I do take it easy most of the time.

98sst 09-02-2009 03:52 AM

My dad just commented saying "well, there goes a 1/4 tank" Ah, phenomenal!


All times are GMT -4. The time now is 09:28 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger