DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   Towing (http://www.ramforumz.com/forumdisplay.php?f=191)
-   -   Tekonsha P3 Trailer Brake Controller Doesn't Recognize Trailer (http://www.ramforumz.com/showthread.php?t=46349)

GTRDude 01-11-2010 10:53 PM

Tekonsha P3 Trailer Brake Controller Doesn't Recognize Trailer
 
Hey there, i have just joined this site but have been lurking in the shadows for some time now. Hopefully you guys can help me todat, and vise versa in the future!

I bought a Tekonsha P3 Trailer Brake Controller and installed it today because i bought a trailer today and needed the brakes. I drive an 07 ram1500 laramie 4x4 with trailer package. I purchased the dodge specific wire harness and the unit powers up and am able to enter the menu's and everything fine.

my problem is that with the trailer attached, the TBC does not recognize the trailer, and gives an error saying so.

i read somewhere that it may be a fuse issue and that if the 3rd brake light doesn't work the brakes wont work. i have checked and everything seems fine.

can anyone help?

dodgeman70592 01-11-2010 11:04 PM

Do you have the factory 7 pin?

GTRDude 01-11-2010 11:15 PM

yes. i have the "factory tow package" :smiley_thumbs_up:

dodgeman70592 01-11-2010 11:20 PM

I have the same controller, the only problem I ever had was when the fuse blew, I think it was #40 which is the same one that controls the third brake light

GTRDude 01-11-2010 11:27 PM

yeah but my third brake light works, i check it 15 minutes ago.

when the fuse blew, did the controller still work? what does that fuse control specifically?

dodgeman70592 01-11-2010 11:38 PM

When the fuse blew, the controller still powered up using the manual boost lever, but would not operate when I applied the brakes. The fuse in question is for high stop light and for a brake control. When mine blew, my carco lights still worked and the brake lights on my trailer still worked, that fuse controls the power to applying the electric brakes, thus causing a fault on the controller. But appearantly this is not the same issue you are facing. It may be an issue with the unit, or possibly a bad connection on the trailer.

GTRDude 01-11-2010 11:53 PM

thanks for the help so far!

i plan on connecting to a buddies trailer tomorrow and narrowing the list of possible problems.

ill post an update tomorrow and maybe get this thing figured out :wavey:

dodgeman70592 01-11-2010 11:59 PM

Yeah,let us know the verdict

CdnoilRAM 01-12-2010 01:30 AM

Let us know how the other trailer test goes. I have issues with my Ford's TBC not recognizing trailers, but since I've started carrying terminal cleaning foam and spraying both connections before I hook up I've had no problems. If there's any corrosion on the connections then they can have trouble recognizing it's there. Just my experience with TBCs.

GTRDude 01-12-2010 05:00 PM

thanks for the suggestion CdnoilRAM i will give that a try

as for the trailer test, 2 more trailers are not recognized.

i guess i will now see if someone has a TBC i can swap for another test and determine if its the TBC or the wiring.

does anyone know how i could test this theory another way? the only person i can think of that i might be able to call is the guy i bought the TBC from on Kijiji.ca. He has the exact same model i saw in his truck, but hes located far away :smiledown:


All times are GMT -4. The time now is 06:12 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger