DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   5.9L V8 Specific Topics (http://www.ramforumz.com/forumdisplay.php?f=184)
-   -   Vehicle Speed Sensor Issues (Dead Speedo) (http://www.ramforumz.com/showthread.php?t=48915)

Zekery360 03-01-2010 05:22 PM

Vehicle Speed Sensor Issues (Dead Speedo)
 
Recently, after washing my truck to look beautiful, my speedometer went dead. I also have a code P0500, VSS Malfunction. So, I have a couple questions to assist in my diagnosis. 1) Is there more then one sensor that could cause the issue? My Ford buddy (I know, apples to oranges, but bear with me) says he has 2 sensors that affect his speedo. So, is it just my one sensor, or is there another in the diff or something? and 2) The diagnostic flowchart I got off of Alldata in my school shows a bunch of tests on the PCM. I am wondering if it is ok to run tests without taking the Superchips tune off, or if I should return my truck to stock first. I have looked for any fuses, couldn't find one that even sounded like it protected the VSS, the sensor is not shorted in itself, and I couldn't get continuity from the connector side back. I also could not find any frayed wires or anything that could have gotten wet and shorted out. Everything was still loomed up really nice just like from the factory. Any help would be greatly appreciated.

Thanks guys! :smileup:

RamTech 03-01-2010 07:12 PM

Unless you have an open or short in the wiring between the PCM and CAB, you probably have a PCM that has bit the dust.

Zekery360 03-01-2010 07:53 PM

So I'm guessing my best bet is just follow my flowchart to the end? Also, anyone have any idea how much a PCM might cost? I would be looking for just a factory one, cheap as I can get it with it still being reliable. Just don't wanna get screwed by the dealer at all.

2000 Ram 2500 03-01-2010 09:25 PM

There should be a resistance test for the VSS. That is the one in the rear differential and is usually the culprit, not to mention cheap fix(Under 25.00). The other sensor that your Ford friend is speaking of is the OSS. It is a different circuit all together.

RamTech 03-01-2010 09:35 PM

According to Chrysler service info, a VSS or OSS will not set this code. Possible causes are an open circuit, short to power, short to ground or a bad PCM.

Zekery360 03-01-2010 10:28 PM

That helps a ton. Thanks guys, now I know where to start at least. I wish it would be the sensor, those are easy as pie to do. Guess I'll start chasing wires around.

DaveDees 03-02-2010 01:37 AM

Symptoms of a P0500 DTC may include:
  • loss of anti-lock brakes
  • the "anti-lock" or "brake" warning lamps on the dash may be lit
  • the speedometer or may not work properly (or at all)
  • your vehicle's RPM limiter may be decreased
  • the shifting of an automatic transmission may become erratic
  • other symptoms may also be present

A code P0500 may mean that one or more of the following has happened:
  • The Vehicle Speed Sensor (VSS) is not reading (functioning) properly
  • There is a broken/frayed wire leading to the vehicle speed sensor
  • The vehicle's PCM is not correctly configured for the actual tire size on the vehicle

The simplest thing to do is to reset the code and see if it comes back.
Next, check all wiring and connectors that lead to the speed sensor. The location of the sensor depends on your vehicle. The sensor could be on the transmission, or perhaps the wheel hub (brake) assembly.
If the wiring and connectors are OK, then check the voltage at the speed sensor. Again, the exact procedure wil depend on your make and model of vehicle.
If everything looks OK, replace the sensor.

papabeer57 05-16-2013 11:10 PM

Will the vss make the tach quit also????

WarsawAndy 05-18-2013 12:28 AM

I've got a similar issue. I've gone ahead and replaced all 3 sensors. I even opened up the pumpkin to make sure the original sensor wasn't in pieces on the inside (i hear it's a common problem). It seems like my speedo only works intermittently and my ABS and brake light are on as well. I sent it to a friend of mine (a mechanic) he told me that it's either the gauge cluster or the body control module. I'm mostly confused because I thought the BCM and cluster are one piece???

jmasar 06-27-2014 10:37 PM

today my truck lost all transmission fluids due to broken hose and get overheated now I'm getting error p0500 and engine light is on both speed sensors was replaced one on the transfer case and the one on rear differential my programmer wont clear the error it always come back need help also my speedo and abs don't work , but it was like this for long time


All times are GMT -4. The time now is 05:52 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger